Giacomo Petrini

Firmware that worked and now it works no more

Discussion created by Giacomo Petrini on Jan 29, 2009
Latest reply on Feb 2, 2009 by Giacomo Petrini
Hi, I'm using a 56F8037, Codewarrior 8.2.3 and Quickstart 2.3. I've this firmware (written by me) that was working until last summer (last time I checked). Yesterday I did some modification and is orking no more (even the unmodified version). The only thing that is changed is CW that now is v. 8.2.3 and before was version 8.2 (or even older, maybe 8.1). The debugging tell me nothing. I download the firmware from CW, I enter the debug mode and go step by step to see what happens. When I arrive to the ArchEnableInt() instruction (asm(bfclr #0x0300,SR)) the window goes blank as if the program is running. If I stop the program, it stops _always_ on the same code line: in startup.c where the pll_lock label is (line 300). I've other projects using CW 8.2.3 that works without problem, but this one probably is the only one that I created with an older version of CW and reopened with the 8.2.3. I read the changelog of CW, but I found nothing useful. Some ideas? Thanks Bye Jack

Outcomes