AnsweredAssumed Answered

Can't connect to FRDM-KE15Z

Question asked by Andre Lipinski on Jan 31, 2019
Latest reply on Feb 1, 2019 by Andre Lipinski

Hi,

I'm having trouble with my FRDM-KE15Z. After three days of nothing but smooth and easy work trying out this nifty board, today it doesn't want to connect properly. The drive appears on my Mac, the green and amber LED's come on and the red LED flickers during the resets, but no downloading. Opening a terminal to the board works and the amber LED flashes when I type, but there's no program in the MCU to do anything as it has been erased by this point in the process. My LPCXpresso845MAX, which also arrived on Monday works perfectly, though. (FYI: I'm using one board at a time.) I've pasted in the logs below. Could you help, please?

 

Thank you very much,

Andre.

 

————————————— RedlinkServer —————————————

[Started server]

[Connected on port 3025]

redlink> ProbeList

Index = 1

Manufacturer = ARM

Description = DAPLink CMSIS-DAP

Serial Number = 0213000036934e45003c40149f3500130e61000097969900

VID:PID = 0D28:0204

Path = USB_0d28_0204_fa140000_ff00

redlink> ProbeStatus

Index = 1

Manufacturer = ARM

Description = DAPLink CMSIS-DAP

Serial Number = 0213000036934e45003c40149f3500130e61000097969900

VID:PID = 0D28:0204

Path = USB_0d28_0204_fa140000_ff00

IsOpen = FALSE

WireInitialized = FALSE

WireProtocol = JTAG

CoresConfigured = FALSE

PacketSize = 64

Reference Count = 0

HasSWV = FALSE

HasETM = FALSE

HasJTAG = TRUE

HasSWD = TRUE

Probe Type = CMSIS-DAP

Probe Reference Count = 0

redlink> ProbeList

Index = 1

Manufacturer = ARM

Description = DAPLink CMSIS-DAP

Serial Number = 0213000036934e45003c40149f3500130e61000097969900

VID:PID = 0D28:0204

Path = USB_0d28_0204_fa140000_ff00

redlink> ProbeStatus

Index = 1

Manufacturer = ARM

Description = DAPLink CMSIS-DAP

Serial Number = 0213000036934e45003c40149f3500130e61000097969900

VID:PID = 0D28:0204

Path = USB_0d28_0204_fa140000_ff00

IsOpen = FALSE

WireInitialized = FALSE

WireProtocol = JTAG

CoresConfigured = FALSE

PacketSize = 64

Reference Count = 0

HasSWV = FALSE

HasETM = FALSE

HasJTAG = TRUE

HasSWD = TRUE

Probe Type = CMSIS-DAP

Probe Reference Count = 0

redlink> ProbeIsOpen 1

FALSE

redlink> ProbeOpenByIndex 1

Probe Handle 1 Open

redlink> WireIsConnected 1

FALSE

redlink> WireSwdConnect 1

DpID = 0BC11477

redlink> CoresConfigured 1

FALSE

redlink> CoreConfig 1

Number of CORES/TAPs = 1, Fully recognized: True

redlink> ProbeStatus

Index = 1

Manufacturer = ARM

Description = DAPLink CMSIS-DAP

Serial Number = 0213000036934e45003c40149f3500130e61000097969900

VID:PID = 0D28:0204

Path = USB_0d28_0204_fa140000_ff00

IsOpen = FALSE

WireInitialized = FALSE

WireProtocol = JTAG

CoresConfigured = FALSE

PacketSize = 64

Reference Count = 0

HasSWV = FALSE

HasETM = FALSE

HasJTAG = TRUE

HasSWD = TRUE

Probe Type = CMSIS-DAP

Probe Reference Count = 0

redlink> quit

[Closed]

 

 

————————————— GUI Flash Tool Console —————————————

============= END SCRIPT =============================

Probe Firmware: DAPLink CMSIS-DAP (ARM)

Serial Number:  0213000036934e45003c40149f3500130e61000097969900

VID:PID:  0D28:0204

USB Path: USB_0d28_0204_fd132100_ff00

Using memory from core 0 after searching for a good core

connection failed - Nn(05). Wire ACK Fault in DAP access.. Retrying

Using memory from core 0 after searching for a good core

Failed on connect: Nn(05). Wire ACK Fault in DAP access

Connected&Reset. Was: NotConnected. DpID: 40000000. CpuID: 00000000. Info: <None>

Last stub error 0: OK

Last sticky error: 0x0 AIndex: 0

Debug bus selected: MemAp 0

DAP Speed test unexecuted or failed

Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.

(100) Target Connection Failed

error closing down debug session - Nn(05). Wire ACK Fault in DAP access

Unable to perform operation!

Command failed with exit code 1

 

 

————————————— GDB Traces —————————————

052,079 (gdb)

052,080 15-interpreter-exec console "set mi-async"

052,081 =cmd-param-changed,param="mi-async",value="on"

052,083 15^done

052,083 (gdb)

052,084 16-interpreter-exec console "set remotetimeout 60000"

052,086 =cmd-param-changed,param="remotetimeout",value="60000"

052,087 16^done

052,087 (gdb)

052,360 17-target-select extended-remote | crt_emu_cm_redlink -msg-port=49530 -g -mi -2 -pMKE15Z256x\

xx7 -vendor=NXP --connectscript=kinetisconnect.scp  --reset= -ProbeHandle=1 -CoreIndex=0 -cache=disa\

ble --flash-driver= -x /Users/high/Documents/MCUXpressoIDE_10.3.0/workspace/.mcuxpressoide_packages_\

support/MKE15Z256xxx7_support --flash-dir /Users/high/Documents/MCUXpressoIDE_10.3.0/workspace/.mcux\

pressoide_packages_support/MKE15Z256xxx7_support/Flash --telnet 3330

053,516 17^error,msg="Remote connection closed"

053,516 (gdb)

053,517 18-target-disconnect

053,517 19-gdb-exit

053,524 18^error,msg="You can't do that when your target is `exec'"

053,525 (gdb)

053,525 19^exit

 

————————————— Debug Messages —————————————

MCUXpresso IDE RedlinkMulti Driver v10.3 (Nov 28 2018 02:37:51 - crt_emu_cm_redlink build 748)

Found part description in XML file MKE15Z7_internal.xml

Reconnected to existing link server

Connecting to probe 1 core 0 (using server started externally) gave 'OK'

============= SCRIPT: kinetisconnect.scp =============

Kinetis Connect Script

Connecting to Probe Index = 1

This probe = 1

This TAP = 0

This core = 0

DpID = 0BC11477

Assert NRESET

Reset pin state: 00

Power up Debug

MDM-AP APID: 0x001C0020

MDM-AP System Reset/Hold Reset/Debug Request

MDM-AP Control: 0x00000008

MDM-AP Status (Flash Ready) : 0x00000036

Part is secured

Mass Erase Required

============= END SCRIPT =============================

Probe Firmware: DAPLink CMSIS-DAP (ARM)

Serial Number:  0213000036934e45003c40149f3500130e61000097969900

VID:PID:  0D28:0204

USB Path: USB_0d28_0204_fa140000_ff00

Using memory from core 0 after searching for a good core

connection failed - Nn(05). Wire ACK Fault in DAP access.. Retrying

Using memory from core 0 after searching for a good core

Failed on connect: Nn(05). Wire ACK Fault in DAP access

Connected&Reset. Was: NotConnected. DpID: 00000000. CpuID: 00000000. Info: <None>

Last stub error 0: OK

Last sticky error: 0x0 AIndex: 0

Debug bus selected: MemAp 0

DAP Speed test unexecuted or failed

Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.

(100) Target Connection Failed

error closing down debug session - Nn(05). Wire ACK Fault in DAP access

Outcomes