AnsweredAssumed Answered

Have no wayland desktop and could not run application with -platform wayland

Question asked by tsung li wang on Nov 26, 2018
Latest reply on Nov 27, 2018 by tsung li wang

Hi Community,

I'm using Yocto project imx-4.9.11_1.0.0_ga and I use i.MX6 sabre-SD Quad as my platform.

 

I use below Distro and build image with below commands.

  1. DISTRO=fsl-imx-wayland MACHINE=imx6qsabresd source fsl-setup-release.sh -b build-wayland-q
  2. bitbake fsl-image-qt5

 

Compiler is success and I got fsl-image-qt5-imx6qsabresd-20181126013844.rootfs.tar.bz2 in the path of build-wayland-q/tmp/deploy/images/imx6qsabresd.

 

After I burn new root file system and zimage and module, logo could show on panel but when get into system there is no desktop showing.

I try to run my application with "./application -platform wayland" then will result failed like below content.

Failed to create display (No such file or directory)

I also tried to use eglfs and wayland-egl, they all reply the same error as wayland.

 

Did I miss anything?

How can I solve this problem?

 

Thanks in Advanced!

Outcomes