AnsweredAssumed Answered

g2d_clear and blit fails with GPU_alloc'd memory

Question asked by Mark Cowan on Oct 2, 2018
Latest reply on Oct 16, 2018 by Bio_TICFSL

What are the correct settings to use when installing galcore (insmod galcore) for the vivante 5.0.11 binaries.  I currently have the GPU marginally running with the following settings.  However I get a device fault from another device driver, which uses DMA, whenever I execute the g2d_clear command on the g2d_surface. 

 

I load the module from with in the embedded application with the following settings for our i.MX6 solo:

 " insmod /lib/modules/3.0.35/kernel/drivers/mxc/gpu-viv/galcore.ko" \
        " registerMemBase=0x00000000 registerMemSize=0x00004000 irqLine=-1" \
        " irqLine2D=42 registerMemBase2D=0x02200000 registerMemSize2D=0x00004000" \
        " irqLineVG=43 registerMemBase2D=0x02204000 registerMemSize2D=0x00004000" \
        " signal=48  baseAddress=0x80000000 fastClear=-1 " \
        " contiguousSize=0x006f50000 contiguousBase=0x9E000000 " );

 

If I use IPU allocated memory for the surfaces, the g2d_blit function works correctly, but slowly.  It does not work when I allocate memory from the g2d driver. 

 

Thank you

Outcomes