AnsweredAssumed Answered

Installation failure of MPC560xP AutoSAR Development tools

Question asked by weilin ge on Feb 22, 2018

Dear:
I am an embedded software engineer, and I am preparing to learn AutoSAR software and its development methods. I learned from NXP that you have provided free AutoSAR MCAL and OS for MPC560xP family chips, and I downloaded them. But when I tried to install these tools software and tools, there were some errors, so I failed to install it. Please help me to solve it, thank you.
I downloaded and intalled  the following:
1.Elektrobit Tresos Studio /Autosar Configuration Tool
It was successfully intalled and worked ok.
2. AutoSAR OS / MPC5600_AUTOSAR_OS_4.0.69_1.0.0_RTM.exe and license(renamed as os_license.dat)
Installation failed and the message box gives a "No feature AUTOSAROS_SOURCES_4_0_69 in ...\license.dat" . But it can be installed successfully when deselected with "Sources" options.
3.Autosar MCAL / MPC560XP_MCAL4_0_RTM_1_0_1.exe and license(renamed as mcal_license.dat)
Installation failed when checking license and the message box gives a "invalid license. Feature AUTOSAR_MCAL_XPC560XP version 4.0 is required" .

Please help me to solve these problems. Thanks again.

Outcomes