AnsweredAssumed Answered

How to fix "Invalid project path"?

Question asked by Jorge Ferreiro on Feb 14, 2018
Latest reply on Feb 16, 2018 by Jorge Ferreiro

Hi

 

I am new in this MCU programming business. I am having problems with the paths during the Building process and I can't find the problem by myself. I have tried to find solutions by looking at similar problems but non of them work for me. Situation:

 

I have a ready project for a MK20DN512 MCU. We want to be able and modify bits of the code ourselves and create a flash file (s19) to update the firmware. I know how to create this s19 files. I have also tried one of those hello world projects for a MK60 MCU and it has worked fine. The main issue is to build the project for our own code. I always get the warning

 

Invalid project path: Include path not found (C:\Users\user\workspace\Freescale_MQX_4_1\lib\xxxx.cw10gcc\debug).   xxxx        pathentry    Path Entry Problem

 

xxxx stands for the name of the project. The problem here ist that there is no folder Freescale_MQX_4_1 and subsquent folders. I have tried deleting/adding/modyfing paths for compiler and/or assembler but nothing works. If I ignore the warnings and try to build the project, I recieve the error

 

min32gw-make No rule to make target

 

I have found out that this has to do with the makefile but I don't find the solution to the problem. Any suggestions?

 

Using: Codewarrior Developmet Studio, 11.0 on a Windows machine

 

Regards

Jorge

Outcomes