AnsweredAssumed Answered

uImage for ls1012frdm?

Question asked by RandyKrakora Employee on Oct 6, 2017
Latest reply on Oct 8, 2017 by Pavel Chubakov

Trying to generate uImage for ls1012frdm board to boot from network.

 

I built yocto sdk 2.0 for Qoriq using ls1012afrdm as machine, all builds fine, but I do not get uImage file, only Image file.

In the instructions for Qoriq SDK to boot tftp and nfs mount, you need uImage file:

 

Section 4.4.1.9.3 in QorIQ-SDK-2.0-1703-IC-Rev0.pdf:

4. Booting up the System
TFTP the kernel image to the board, then boot it up.
=>tftp 1000000 <uImage name>
=>tftp c00000 <platform dtb name>
=>bootm 1000000 - c00000
Now the board will boot up with NFS filesystem.

 

So I tried modifying local.conf with this:

KERNEL_IMAGETYPE = "uImage"

 

Then tested with this:

bitbake -e fsl-image-core | egrep ^"KERNEL_IMAGETYPE"

 

But still get image type as Image, not uImage. So I modifed this file:

./meta-nxp-npi-1703/conf/machine/ls1012afrdm.conf

to add this:

KERNEL_IMAGETYPE = "uImage"

 

Then tested with this:

bitbake -e fsl-image-core | egrep ^"KERNEL_IMAGETYPE"

And now I get image type as uImage, so I built "bitbake virtual/kernel" and get this error:

 

Log data follows:
| DEBUG: Executing shell function do_compile
| NOTE: make -j 4 uImage CC=aarch64-fsl-linux-gcc -fuse-ld=bfd --sysroot=/media/rfkrakora/rfk-1TB/LS-Qoriq/sdk-2.0/QorIQ-SDK-V2.0-20160527-yocto/build-ls1012frdm/tmp/sysroots/ls1012afrdm LD=aarch64-fsl-linux-ld.bfd --sysroot=/media/rfkrakora/rfk-1TB/LS-Qoriq/sdk-2.0/QorIQ-SDK-V2.0-20160527-yocto/build-ls1012frdm/tmp/sysroots/ls1012afrdm LOADADDR=20008000
| GEN ./Makefile
| scripts/kconfig/conf --silentoldconfig Kconfig
| make[2]: *** No rule to make target 'uImage'. Stop.
| Makefile:146: recipe for target 'sub-make' failed
| make[1]: *** [sub-make] Error 2
| Makefile:24: recipe for target '__sub-make' failed
| make: *** [__sub-make] Error 2
| ERROR: oe_runmake failed
| ERROR: Function failed: do_compile (log file is located at /media/rfkrakora/rfk-1TB/LS-Qoriq/sdk-2.0/QorIQ-SDK-V2.0-20160527-yocto/build-ls1012frdm/tmp/work/ls1012afrdm-fsl-linux/linux-qoriq/4.1-r0/temp/log.do_compile.4231)

 

How can I get uImage to boot from the network? ( uboot is using bootm )

 

Regards,

Randy Krakora

Outcomes