AnsweredAssumed Answered

How to disable the fec2 from the devicetree in imx6ulevk

Question asked by Sourabh Das on Sep 23, 2016
Latest reply on Aug 6, 2018 by Francesco Serpetti

Hi,

I am using imx6ul-evk board, which has two ethernet ports. In our custom board, we will be having only one ethernet. So, I tried to disable the fec2 in the detree, by making status="disabled" in its entry.

I was getting the error on booting:

Configuring network interfaces... ifconfig: SIOCSIFFLAGS: No such device

Also the eth0 or eth1 interface was not comming on doing ifconfig.

 

Next I tried by removing the fec2 entry from the board devicetree file, and creating a mdio entry in fec1. This time on booting, I was getting:

fec 2188000.ethernet eth0: Freescale FEC PHY driver [Generic PHY] (mii_bus:phy_addr=2188000.ethernet:02, irq=-1)
IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready

 

I am getting eth0 interface on doing ifconfig, but I am not able to ping ip of my pc.

Please suggest me something on this, on how to disable the fec2 from devicetree.

Outcomes