AnsweredAssumed Answered

How do I get a reliable K22 connection from the LS102A-IOT Reference Design?

Question asked by Thomas Thorne on Jul 7, 2016
Latest reply on Aug 22, 2016 by Thomas Thorne

I have a TechNexio freescale LS1021A-IOT reference design box but I cannot get it to reliably come up and provide a serial connection.  This is using the supplied SDHC card, with the supplied image.  I have got a serial console to come up a handful of times in the last two days but I am not sure what happened those times to make it work. 

 

I have tried on both Ubuntu and Windows 7.  Almost every time the box is powered up an mBed Serial Port and MBED storage drive are detected over the USB0 K22 connection.  Most times I can get the K22 LED to flicker when I am typing in a connected console terminal.  Seldom will any output come from the box. 

 

What am I doing wrong? 

I have tried following the instructions in the QorIQ LS1021A-IOT Gateway Reference Design Getting Started Guide (Document Number: Ls1021A-IOTGS Rev 2, 02/2015).  I tried using different USB ports on the PCs.  Reinstalling the USB drivers.  Connecting an HDMI monitor and USB keyboard; the monitor never displays but the keyboard will respond to Caps Lock when the terminal works but not the rest of the time.  I have wiggled the SD Card, used dd to copy it.  Checked it reads OK under Linux via a SD Card reader. 

The status LEDs that come on are always K22, PWR and LED0, never DEBUG. 

The supplied SD card seems to have on it 3 partitions:

  • 4.2MB Free
  • 3.9GB FAT
  • 4GB Free

The FAT partition has 3 files named; fsl-image-rds-iot-ls1021aiot.ext2.gz.u-boot, uImage-ls1021aiot.bin and uImage-ls1021aiot.dtb. 

 

On the odd occasion it booted I was able to reboot to exit Linux, catch the uBoot and look at the startup scripts.  I can type those out from my notes if it would be helpful. 

Outcomes