lpcware

LPCXpresso 7.2.2 doesn't start properly with a particular workspace (Solved)

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by fjrg76 on Sun May 10 15:40:29 MST 2015
Hi,

I have my workspaces under Copy.com (similar to Dropbox) and a desktop client for this tool in all my Linux Mint box's. As is, I work with some particular workspace in my desktop PC, and then in my laptop on a daily basis.

Until yesterday everything was ok, but suddenly such a workspace made the IDE to stop when opening it. Only a small gray window shows up with "LPCXpresso" text on the window bar, and then it is stucked.

Thinking it was a problem with Linux Mint 17.1 64Bits box I uninstalled it and then I reinstalled it, but the problem still existed. So I tried with another workspace (also on my Copy.com folder) and LPCXpresso opened it with no problems. So, the conclusion is that there is something wrong with the original workspace I was using, may be it is corrupted.

My question is: Are there ways to repair or fix the workspace in which I don't need to delete or lost the job done?

Thank you!

Update: In the workspace's directory I found the .log file, and within a relevant line:

...
Command-line arguments:  -os linux -ws gtk -arch x86

!ENTRY org.eclipse.core.resources 2 10035 2015-05-10 17:49:09.802
!MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes.

!ENTRY org.eclipse.osgi 4 0 2015-05-10 17:49:09.874
!MESSAGE An error occurred while automatically activating bundle org.eclipse.core.resources (113).
!STACK 0
org.osgi.framework.BundleException: Exception in org.eclipse.core.resources.ResourcesPlugin.start() of bundle org.eclipse.core.resources.
...


I'm attaching the complete .log file (with .txt extension) if someone wants to look deeper.

Original Attachment has been moved to: log_7.txt.zip

Outcomes