lpcware

How to use the Run button of LPXExpresso?

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by zapta on Fri Aug 08 15:08:14 MST 2014
Hi all, my first posting here.

I installed LPC Expresso 7.3.0 on Mac OSX 10.9.4 and am trying to work my way though the provided examples using this board in default setting (I didn't change any jumper)

http://www.digikey.com/product-detail/en/OM13014,598/568-7517-ND/2700004

I am able to build run and debug programs using the LPCExpresso's Debug button but could not figure out how to run using the Run button (I am expecting a simpler process than Debug, without having to switch perspective, resume from the initial breakpoint, etc).

Any idea how to make the Run button to work? I tried both Debug and Release configuration, my board is connected correctly with USB cable (and the Debug button does work), I tried the option 1 and 2 of the Run As menu (what's the difference between 'Local' and 'MCU application'?) but nothing.

Any help will be greatly appreciated, or at least tell me if it works or doesn't work for you.

BTW, I found here a year old non answered question on the topic http://www.lpcware.com/content/forum/starter-project-can-debug-not-run-lpcxpresso-5

Thanks,

zapta.

Outcomes