lpcware

Cannot halt 43xx cores

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by chris_bayley_trimble on Wed Dec 17 14:24:56 MST 2014
I am relatively new to LPC stuff, but am working on a new product incorporating dual HS USB so have been working with USB sample code on several Xplorer-43xx boards and an Xplorer-18xx board.
Yesterday without warning all of my 43xx boards began giving problems with the debugger and started returning a 'Cannot halt processor' error when initiating debug' as below.
LPCXpresso RedlinkMulti Driver v7.5 (Oct 24 2014 22:19:37 - crt_emu_cm_redlink build 172)
Found chip XML file in /Users/cbayley/src/NXP/LPCOpen/Xplorer4330/LPC4357_test/Debug/LPC4357.xml
(  5) Remote configuration complete
Cannot halt processor
Cannot halt processor
Emu(0): Conn&Reset. DpID: 4BA00477. CpuID: 410FC240. Info: (null)
Debug protocol: JTAG. RTCK: Disabled. Vector catch: Disabled.
Cannot halt processor
Failed on chip setup: Ep(04). Cannot halt processor.

I can't identify what may have caused this change in behaviour. At first I suspected the LPCLink-2 but it is still working fine with the Xplorer-18xx board. The 43xx boards I can connect to and halt using OpenOCD and a luminary probe but I haven't yet succeeded in incorporating that into LPCXpresso so I'm still a bit stuck. I've tried with many projects which have all previously been fine, I have tried switching to SWD, but I'm not getting very far.

What things can cause a failure of LPCLink2/RedLink to halt a 43xx processor ? A boot setting ?, some OTP bit ?, ??

I've spent a few hours wrestling with it and would be glad of some suggestions at this point.

Cheers,
Chris

Outcomes