lpcware

SPIFI Interface with LPC1850 issue

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by Noufal on Tue Sep 29 08:27:22 MST 2015
Hello,

I'm trying to interface 1850 with SPIFI S25FL032 in Keil enviromnet, My issue is I'm able to program the spifi with Keil algorithm, but when in tried to run the program from spifi it does not work.

I tried different options

1. Tried to put the jumber to boot from spifi and put all my boot routine in spifi region. Not even coming to SystemInit routine in the system startup

LR_ROM1 0x14000000 0x00400000  {    ; load Spifi region size_region
  ER_ROM1 0x14000000 0x00400000  {  ; load address = execution address

   *.o (RESET, +First)
   *(InRoot$$Sections)
     *RTX_CM3.lib (+RO)
    RTX_Conf_CM.o (+RO)  
.ANY (+RO)
  }

2. Tried to load from external flash and added few images in the spifi region

Both did not work, Is there any initialization need to be done in the application for Spifi to work in read only mode ? I'm not writing anything on run time now?

When I run the  keil example Blinky from spifi  it does work from my board. I'm not sure what i'm doing wrong? Please help

Outcomes