AnsweredAssumed Answered

U:1920x1080p-35

Question asked by fulin chen on May 3, 2016
Latest reply on May 5, 2016 by fulin chen


Dear all,

this is my configure of lcd panel:

    mxcfb1: fb@0 {

            compatible = "fsl,mxc_sdc_fb";

            disp_dev = "ldb";

            interface_pix_fmt = "RGB24";

            mode_str ="LDB-1080P60";

            default_bpp = <32>;

            int_clk = <0>;

            late_init = <0>;

            status = "okay";

    };

 

&ldb {

    status = "okay";

    split-mode;

 

 

    lvds-channel@0 {

        fsl,data-mapping = "spwg";

        fsl,data-width = <24>;

        crtc = "ipu2-di0";

        primary;

        status = "okay";

 

 

        display-timings {

            native-mode = <&timing0>;

            timing0: hsd100pxn1 {

                clock-frequency = <83000000>;

                hactive = <1920>;

                vactive = <1080>;

                hback-porch = <80>;

                hfront-porch = <68>;

                vback-porch = <15>;

                vfront-porch = <15>;

                hsync-len = <12>;

                vsync-len = <8>;

            };

        };

    };

    lvds-channel@1 {

        fsl,data-mapping = "spwg";

        fsl,data-width = <24>;

        crtc = "ipu2-di1";

        status = "disabled";

 

 

        display-timings {

            native-mode = <&timing1>;

            timing1: hsd100pxn1 {

                clock-frequency = <83000000>;

                hactive = <1920>;

                vactive = <1080>;

                hback-porch = <80>;

                hfront-porch = <68>;

                vback-porch = <15>;

                vfront-porch = <15>;

                hsync-len = <12>;

                vsync-len = <8>;

            };

        };

    };

};

 

kernel:

# cat /proc/cmdline

noinitrd console=ttymxc0,115200 root=/dev/mmcblk0p1 rw init=/linuxrc video=mxcfb0:dev=ldb,LDB-1080P60,if=RGB24,bpp=32 consoleblank=0 ldb=spl0 ldo_active=on

# cat /sys/class/graphics/fb0/modes

U:1920x1080p-35

 

why my refresh frequency is 35Hz, i need 60Hz or 75Hz, how can i do that?

thank you,

fulinux.

Outcomes