AnsweredAssumed Answered

LS1021A Rev 2 : First time QSPI NOR Programming

Question asked by SANJU VARGHESE on Jan 21, 2016

Hi,

I am facing one issue in programming a custom LS1021A rev 2.0 board. The board only has a QSPI NOR flash for booting. For the first time programming I tried with the hard-coded RCW to load the RCW to QSPI flash. I failed to load.  I checked the Reference manual, the hard-coded RCW is not having the QSPI pin-muxing. I can access all the processor registers and DDR memory,but no activity in the QSPI lines when I am trying the QSPI address 0x40000000 as the pinmuxing not for the QSPI in hard-coded RCW.  

I tried giving the RCW through the JTAG configuration chain with the QSPI pinmuxing and RCW override option enabled, some new error came "Failed to configure the JTAG chain". I tried giving different RCW through the configuration file but no luck. I attached one configuration file for reference.

Can anyone provide me a valid JTAG configuration chain for programming the LS1021A QSPI flash?

 

 

Thanks in advance

 

 

Sanju

Original Attachment has been moved to: LS1021A_custom.txt.zip

Outcomes