AnsweredAssumed Answered

A question about LTIB on imx6q

Question asked by paul L on Jan 11, 2016
Latest reply on Jan 11, 2016 by Yuri Muhin

I have downloaded the BSP from the official website.And now I want to install LTIB on the UBUNTU14.04.According to the document I have install some libraries which the LTIB rely on.

 

sudo aptitude -y install gettext libgtk2.0-dev rpm bison m4 libfreetype6-dev

sudo aptitude -y install libdbus-glib-1-dev liborbit2-dev intltool

sudo aptitude -y install ccache ncurses-dev zlib1g zlib1g-dev gcc g++ libtool

sudo aptitude -y install uuid-dev liblzo2-dev

sudo aptitude -y install tcl dpkg

sudo aptitude -y install asciidoc texlive-latex-base dblatex xutils-dev

sudo apt-get install texinfo

 

And I have installed zlib1g & zlib1g-dev.According to the command:apt-cache policy,I am sure this two have been installed.After LTIB been installed ,some mistakes happen as follows when I run it:

 

defined(@array) is deprecated at /usr/local/arm/LTIB/ltib/bin/Ltibutils.pm line 362.

    (Maybe you should just omit the defined()?)

 

ltib cannot be run because one or more of the host packages needed to run it

are either missing or out of date or not in ltib's standard path.  Please

install/upgrade these packages on your host.  If you have your own utilities

in non-standard paths, please add an entry into the .ltibrc file for example:

 

%path_std

/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/my/own/exes

 

Package                Minimum ver   Installed info

-------                -----------   ---------------

zlib-devel             0             not installed

 

Died at ./ltib line 1409.

traceback:

main::host_checks:1409

  main:554

 

 

Started: Tue Jan 12 11:51:18 2016

Ended:   Tue Jan 12 11:51:18 2016

Elapsed: 0 seconds

 

 

Build Failed

 

At first there was another error like:zlib            0             not installed

So I found a file named "patch-ltib-ubuntu12.04.sh"and run it .Then this item disappeared.What should I do now?How can I install zlib-devel i need?

Outcomes