AnsweredAssumed Answered

MQX not booting

Question asked by Joseph Gundel on Apr 21, 2015
Latest reply on Apr 30, 2015 by Radek Sestak

Essentially I followed this guide to building a framework MQX project: How To: Create a New MQX RTOS for KSDK Project in KDS

 

Something must be configured incorrectly in the linker or startup code.

 

If I load the same code from the pre-built example project (rtos hello world), it works fine.  If I try to build my own project from scratch by following these instructions (which I will need to do with a custom board) I run into this issue that appears to be the WDOG_EWM_IRQHandler being called and causing a DefaultISR interrup , even though if you look at the board files the DISABLE_WDOG code appears to be set correctly.

 

Here is the stack trace which happens just a few ms after startup:

 

 

I've tried creating an explicit handler for this (which doesn't fire), I don't know what else to do.  I'm new to the quirks of MQX but I don't know how to make a project that is any simpler and it's already showing issues.

 

Appreciate any help you can give here, thanks.

Outcomes