AnsweredAssumed Answered

MKL26 no interrupts

Question asked by Panayot Daskalov on Feb 10, 2015
Latest reply on Feb 10, 2015 by Panayot Daskalov

Hi All,

 

I have a strange problem. We had a first batch of MKL26Z64 based boards build, tested our software on it and eventually everything worked fine. Of course we found a couple of problems, which were mainly in other modules not in the MCU. We corrected them and made a second batch of those boards and this is where problems came in. The same software runs fine on the first batch of boards, but when we put it on the latest batch it starts but no interrupts routines are being called, not even the SysTick. Needless to say that without interrupts the device is useless. MCU's are 100% the same on both boards, the boards themselves are 90% the same but the behavior is totally different. We tried everything we coulld think of, including making modifications to the new board to be 100% as the old one. We tried to run simple examples on the new board, but if they use interrupts nothing happens. If you put an endless loop, to blink an LED for example, it works so the MCU is alive and kicking but interrupt routines are not being called.

 

Does anybody have an idea what might be the problem?

 

Thanks in advance.

 

Best regards,

Panayot

Outcomes