AnsweredAssumed Answered

V4L2, encoding seems not work.

Question asked by jianhua xu on Nov 13, 2014
Latest reply on Nov 21, 2014 by jianhua xu

Hi Community,

 

We have a application of video conference system, that it will get camera stream and encode to H263 format and send it to another receiver through internet. After runing the system over 12 hours or more for aging test, the encoding seems not work, and my board always prints below log:

 

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

I/FslCameraHAL( 3210): no buffer in v4l2, continue

............

Could you give me some advices about what happen and how to debug next step?

Outcomes