AnsweredAssumed Answered

GDI Protocol fatal error

Question asked by James Tasker on Oct 15, 2014
Latest reply on Oct 16, 2014 by Erich Styger

Hi all,

 

I am using a MC9S08QE32 processor along with CodeWarrior 10.6 and a P&E Multilink Universal for debugging.  I can download the program to the chip and run the program through the debugger, but after some time the program stops and I get a pop-up error: "GDI Protocol fatal error: The Debugger is not connected to the PE device" and then I can no longer reconnect to the device and I get the problem occurred pop up: "... Failed to resume target process."  I then have to restart Codewarrior (ending the DE process doesn't always do it) to be able to reconnect to the target board.

 

Some things that I have tried that have not fixed the problem:

  • Upgraded Codewarrior to 10.6
  • Verified stable power supply to board
  • Used different boards (custom boards with same processor) and I still get the problem on all of the boards
  • Disabled COP Watchdog

 

This problem makes debugging very difficult and any help or suggestions at all is greatly appreciated. 

 

Thanks and please let me know if more information is necessary to help.

Outcomes