AnsweredAssumed Answered

Custom HW based on imx28 unable to boot from linux-3.14 (yocto)

Question asked by Xavi García on Jul 29, 2014
Latest reply on Jul 30, 2014 by Xavi García

Hi people,


I have been working on a i.MX28 EVK development board, i needed to achieve to set an Access Point with the board and I had some dongles to do it:




1 & 2RT5370RT5370STA
1 & 2RT5370RT5572STA



Finally after trying a lot of combinations (several drivers, kernels, ltib.. yocto..) I got the Access Point.

I was only able to have it working with the WN722N dongle, AR9271 chipset, in linux-2.6.35 it gets the ar9271.fw which doesn't work with hostapd, in linux-3.14 fslc compiled with yocto it gets the htc-9271.fw and hostapd has no problems to set the Access Point.

I wasn't able to do the same with the other dongles neither with linux 2.6.35.


The next step was seeing how the SO worked in our custom hardware based on i.mx28. The main differences are:

- Instead of the SSP0 bus of 8bits for the SD used in iMX28 board the custom HW uses 4 bits for the microSD.

- The custom HW doesn't uses battery.


Impossible to boot... 0x8020A014 error --> ERROR_DDI_SD_MMC_DEVICE_NOT_SUPPORTED

I know that have to change "something" in the boot, but i don't know what and how, I tried to change the boot argument "setenv mmcdev 1" but neither this way, same problem.

These are the partitions of the card:

Captura de pantalla de 2014-07-29 11:17:41.png

Maybe need to change something on the partitions?



So in this point I am, need to boot the system on the custom HW and if is possible, have more of the others dongles working, but this seems to be impossible...


This is the second time I post something here, the last time i had no help, hope this time it change!