AnsweredAssumed Answered

Creating/Copying a Project

Question asked by Dave Wills on Jun 13, 2014
Latest reply on Jun 17, 2014 by Dave Wills

Hi,

 

I'm reaching my frustration level with CodeWarrior.  Of course, I'm new to it and it just doesn't feel comfortable.

 

Using a sample project provided by Freescale, I compiled, downloaded and executed on a demo board.  Next, I modified existing files, added new files and developed custom software for my custom target board.  I then got all this working on my custom target board.  Now I'm ready to move away from the sample project to a project that is unique to my custom board.

 

Here is my problem.  The Freescale sample project directory tree is not reasonable for my use.  I need to create a custom tree that fits my need.  What I would really like to do is to create the tree I want and then build a project around it.  I've tried this several different ways, but nothing works for me.  First, there doesn't appear to be any way to tell CodeWarrior to use an existing tree.  You can't add files to a folder that already exist in the folder, so you need to link or copy from another folder.  And when I do this, I need to manually enter all include paths.  Adding the paths is OK, I get that.  But even when I do that I can't get past assembler errors for those .s files in the original project.

 

I've read through some posts on a similar topic and have tried to copy a project.  This creates the copy, but it just links the files to a directory tree that I don't want.  And just by copying the project doesn't work because the include paths are wrong.  I can fix those, but since the tree isn't what I want anyway, I'm not going to go that way.

 

So, basically what I'm trying to do is create a bareboard project for my processor (KE02) with a structure like this:

 

<common folder>

<project folder>

     (multiple standard project folders here)

     source

          (multiple source folders here, possibly including cpu, drivers, etc.)

     headers

          (possibly multiple folders here)

 

The common folder contains files which are shared with projects for other processors (not KE02).

 

What is the easiest way to get here without getting the assembler errors (which I haven't figured out how to eliminate)???

 

Thanks,

 

Dave

Outcomes