AnsweredAssumed Answered

kl04 is secured

Question asked by vinod Karuvat on Mar 6, 2014
Latest reply on Mar 11, 2014 by Perla Andrea Moncada Fajardo
Hello,
I am trying to program a custom board (KL04) via the Multilink.It worked fine, but then it shows the "Device is secure.Erase to unsecure".I keep pressing Yes.
AFter doing this twice the "Multilink" not connected is shown. There was another board that was doing the same.

But, its now, surprisingly working,except this 1 board.

I tried the Processor halt utility. Still no luck.Uninstalled/installed PE drivers. No luck.

Also, no where in the code have I modified that register (FTFA_FOPT or any such dangerous registers:) .

Infact CODE WARRIOR warns you if you make any changes to such registers.).
Also, is there any way I can ensure such a message/error does not occur in any future boards. Can this be done via s/w code or so.
I saw in a site that I can look at the Binary files at the location 0x40C. How can I look at 0x40C. Kindly help me out. This is a disaster as 1 board is beyond recovery

Vinod.

Outcomes