AnsweredAssumed Answered

glfinish takes 5ms for nothing

Question asked by volki on Jan 28, 2014
Latest reply on Feb 24, 2014 by Bio_TICFSL

I'm currently trying to find bottlenecks, as I'm currently not able to archive a full-hd rendering of a texture at 60fps when some additional small overlays are present.

During my timing tests I found out that calling glFinish with no OpenGL command in the queue it already takes 4-5ms before glFinish returns. Is this due to the context switch to kernel space?
But even in case that's the main reason for a delay, it seems quite a bit long to me.

 

Apart from that, is there an easy way to enable the vivante profiler within the yocto toolchain? I couldn't find an option within the kernel menuconfig, although there seems to be a USE_PROFILER option somewhere to be defined.

At least this option is parsed in the KBuild file under drivers/mxc/gpu-viv.

Outcomes