AnsweredAssumed Answered

RTCS examples crashing in MQX 4.0.1

Question asked by Nathan Kohler on Jul 29, 2013
Latest reply on Jul 31, 2013 by Nathan Kohler

I was using MQX 3.7 with Codewarrior 10.2 on my M52259EVB. I want to upgrade to MQX 4.0.1.

 

I downloaded and installed 4.0.1, and am still using CW10.2, then built the libraries in debug and release mode using default user_config.h and intflash.lcf files.  No issues linking or compiling.  Then I built the httpsrv example in the RTCS folder without any problem.

 

When I try to run, it crashes when RTCS_create() is called.  I traced the source of the crash in debug mode to:

 

RTCS_create -> RTCS_task_create -> _task_create() -> task_create_internal()->CHECK_RUN_SCHEDULER()

 

*** UNHANDLED INTERRUPT ***

Vector #: 0  0x0

Offset  : 0  0x0

Task Id: 0x10002 Td_ptr 0x20001f38 Stack Frame: 0x2000312c

Interrupt_nesting level: 1   PC: 0x00000000   SR: 0xf442

 

I tried uninstalling and reinstalling 4.0.1, and also tried a second M52259EVB board.

 

Can anyone confirm that RTCS examples will work in 4.0.1 on the M52259EVB with stock user_config.h?  I compared the user_config.h, small_ram_config.h, and intflash.lcf files between 3.7 and 4.0.1 and they seem to be identical.  The MFS examples and all RTCS examples seem to crash when I try to run them.  All the examples in 3.7 run without issue.

 

I've tried programming using PROGCFZ and also using CodeWarrior 10.2 programmer.  I'm using the Coldfire USB multilink.

 

Any ideas?  Anyone else have this issue?

Outcomes