AnsweredAssumed Answered

Kinetis K40 Flash Programming Failed"

Question asked by gagan garg on May 18, 2013
Latest reply on Nov 19, 2015 by hesane

Hi,

 

I am using Kinetis K40 Tower and Multilink Universal Debuuger to flash and debug the code in IAR. Unfortunately, I received the flashing error saying  "the flash loader program reported an error". Such flashing problem was not reported in past, It was working perfectly earlier. I tried Code Warrior to debug and flash the code but it says "Device Is secured". I have clicked YES in the pop up message to unsecure it but it failed and no code was downloaded.


In code warrior I have also tried to flash the code using the Flash Programmer  (Flash File to Target) and checked the option of Erase and Flash, somehow it completed successfully. Now when I tried the IAR again to check the debugging It shows the different error in which the "Flash Programming pop up window's bar" is not progressing and got stuck in the beginning.


I doubt that program loader in K40 gets corrupted due to  the option of erase and program the chip. I do not understand the cause of this fail in programming the flash. I request if anyone knows what has happened and how to rectify the situation. I would be grateful to you.


I have attached the screenshot of flashing error in IAR.

 

Thanks and regard,

 

Gagan

Attachments

Outcomes