AnsweredAssumed Answered

Is my FDRM-KL25Z broken?

Question asked by lukep on Nov 2, 2012
Latest reply on Nov 4, 2012 by lukep

I got my FDRM-KL25Z in the mail a few days ago, it's my first time using an ARM based MCU (used atmel 8-bit µC's for about a year). It worked fine for a while, I tried some pre-compiled examples and wrote my own blinky program. Always programming it with the MSD flash programmer.

 

Yesterday I tried to flash another example app onto it to try the virtual serial port. However I got the 8 blinks 2 second pause "error" from the LED and the application didn't run. LASTSTAT.txt says "programming...". I tried reloading the MSD programmed SDA application, no dice.

 

So then I tried using the CMSIS-DAP in combination with keil µvision to flash a program to it (one the example projects from the keil MDK). I get three messages: "Kinetis Device is locked! Do you want to unlock it? Mass erase will be executed!" followed by "AGDI-Cortex M error: Cannot access memory". The IDE is configured the right way - if I disconnect the device it simply says "no debug unit found".

 

It seems the openSDA chip works fine, as does the KL25Z128xx. It runs the last program that was on it when programming still worked, and loading new openSDA applications works as well (it recognizes the CMSIS-DAP in keil and the MSD shows up when the MSD programmer application is loaded).

 

Does this mean the board is broken or is there more troubleshooting I should do before I RMA it?

Outcomes