AdCmo

LTIB can't find zlib package, using Ubuntu 11.10 and LTIB 9.1.1

Discussion created by AdCmo on Nov 16, 2011
Latest reply on Apr 9, 2013 by Yuri Muhin

I installed LTIB to /opt/freescale using Ubuntu 11.10 and I am getting this error though I know I installed zlib.

i.e. I installed:

zlib1g,

zlib1g-dbg,

zlib1g-dev and

libghc-zlib-dev.

 

But I am still getting error below when I run:

 

./ltib -m config

 

ltib cannot be run because one or more of the host packages needed to run it
are either missing or out of date or not in ltib's standard path.  Please
install/upgrade these packages on your host.  If you have your own utilities
in non-standard paths, please add an entry into the .ltibrc file for example:

%path_std
/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/my/own/exes

Package                Minimum ver   Installed info
-------                -----------   ---------------
zlib                   0             not installed

Died at ./ltib line 1397.
traceback:
 main::host_checks:1397
  main:542


Exiting on error or interrupt

When I try to reinstall "zlib1g-dev" it says I already have the newest version.

I am using ltib 9.1.1 ($Revision: 1.445.6.1 $)

 

Also aptitude search cannot find zlib-devel.

Anything else I am missing?

Thanks,

Ad.

Outcomes