Alessandro Galassini

[SOLVED] qt 4.7.4 embedded on i.mx28

Discussion created by Alessandro Galassini on Oct 18, 2011

Hello to everybody,

I've tried to install with LTIB qt 4.7.4 library on my i.mx28 (I use Ubuntu 10.04 LTS 64 Bit)

First I've downloaded the Qt libraries 4.7.4 for embedded Linux

First question: What's the difference between qt libraries 4.7.4 for  Embedded and qt-libraries 4.7.4 for Linux/X11?

Why with diff -r command they seem to be identical?

I would install qt library embedded without server X11.

After I've found a patch for 4.7.4 qt-embedded.spec at (http://imxcommunity.org/xn/detail/4103961:Comment:36418). I've patched my qt-embedded.spec (original version 4.6.0) and after some tricks with some libraries I've builded sucessfully the package.

I have in my rootfs under /usr/local/Trolltech/qt-everywhere-opensource-src-4.7.4 some folders.

So it seems ok but I have some problems (cd myrootfs/usr/local/Trolltech/qt-everywhere-opensource-src-4.7.4):

  1. If I try to launch ./bin/qmake I receive ./bin/qmake: line 1: syntax error: unexpected "(" 
  2. if I try to launch ./demos/books/books I receive Illegal instruction
  3. I get same error with other demos

Something is wrong but what?

Maybe my qt-embedded.spec file is not for an i.mx28?Has somebody got a minimal .spec file?

I attach my .spec

 

Thanks in advanced

Original Attachment has been moved to: 623-qtembedded.spec

Outcomes