Vincent Chou

Building Android and compatibility of Fedora on i.MX515EVK

Discussion created by Vincent Chou on Apr 25, 2011
Latest reply on May 9, 2011 by Tak Asami

Hi!  Friends,

When we tried to build Android, we came across these errors:

-------------------------------------------------------------------------------------------------------

1. when executing:
  ./repo init -u git://android.git.kernel.org/platform/manifest.git -b froyo
  I found the error:
--------------------------------------------------------------------------
Traceback (most recent call last):
 File "./repo", line 603, in ?
   main(sys.argv[1:])
 File "./repo", line 570, in main
   _Init(args)
 File "./repo", line 184, in _Init
   _CheckGitVersion()
 File "./repo", line 213, in _CheckGitVersion
   proc = subprocess.Popen(cmd, stdout=subprocess.PIPE)
 File "/usr/lib/python2.4/subprocess.py", line 558, in __init__
   errread, errwrite)
 File "/usr/lib/python2.4/subprocess.py", line 991, in _execute_child
   raise child_exception
OSError: [Errno 2] No such file or directory

----------------------------------------------------------------------------

Has anyone come across these in your experience?  If you do, how do you eliminate these?

 

Also, we tried to build Android in Fedora Core.  We came across a different issue.

-----------------------------------------------------------------------------

2. When generating Android partitions on SD, in r9.2, it takes to use mkfs.ext4 to make
the partitions as ext4 format. But in r8, it can use mkfs.ext3. My Fedora Core don't
have mkfs.ext4, can I use mkfs.ext3 in r9.2?

----------------------------------------------------------------------------

Did anyone try to build ext3 in r9.2 before?

Thanks for the help in advance!

Vincent

Outcomes