Problem while adding ethernet stack with GUI

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem while adding ethernet stack with GUI

240 Views
prasanthapplied
Contributor III

Dear all,

       I'm using IMXRT1064 processor. I need to use Ethernet and GUI Together. So first i create the design using embedded wizard and convert it to the code for MCUXpresso IDE. Then i added Ethernet pins and lwip stack to it. I taken the lwiptcpecho_freertos demo for reference to adding Ethernet and lwip stack. After finished all the modifications i run the program it gives the IP,subnetmask,gateway to the terminal but the board didn't gets ping through a cmd window.

     I don't know why its happens. Please assist me to solve this issue.

Thanks & Regards,

Prasanth.

Labels (1)
Tags (2)
0 Kudos
2 Replies

163 Views
victorjimenez
NXP TechSupport
NXP TechSupport

Hello Prasanth, 

I ran the example lwiptcpecho_freertos that we provide within the SDK and everything went fine. Based on the information that you provided, it seems that the behavior you are facing is due to the merge of the Embedded Wizard project with the SDK example. My recommendation on how to proceed with this would be that in your project you start removing things related to the GUI until you find when the problem goes away. Once you have identified this, you will know which task or resource from the embedded wizard project is causing this behavior. 


Have a great day,
Victor

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

163 Views
prasanthapplied
Contributor III

Dear Victor,

            To do a complete product with a GUI i need to integrate controller peripherals and GUI otherwise its not possible to complete a full product. So if i proceed with GUI only in case of any support GUI persons gives the support. But merging the peripherals only i can't get a support. For example i tried a simple polling method ADC and integrate it with GUI before doing integration i gets an ADC value like 240 something. But after merging it with GUI the values goes like 4010 above and below 100. These both are changed frequently. I don't have a clue for why this happening. So how can i proceed with this?

Thanks & Regards,

Prasanth.

0 Kudos