root file system not properly installed?

Showing results for 
Search instead for 
Did you mean: 

root file system not properly installed?

Contributor I

Dear users,

I have encountered a problem for i.mx6DL board. I have a custom kernel, dtb and rootfs. When I use tftpboot, I can install everything, and everything works. However, I would like to do this over USB, not internet, so I tried using MFGtool2. MFGtool successfully uploads U-boot and custom files, however, when I boot, it just says loading kernel and stays there. I found it that if I erase.part rootfs, and put it back on via tftp it boots and everything works again. Therefore I suspect something wrong with the way MFGtool installs the rootfs. I looked in the batch file of MFGtool, but I did not find anything that could help me. I tried changing the compression from .bz2 to .tgz since it accepts several formats, but so far no luck. It just stays at 'booting kernel' and that is about it.  Has anyone encountered this, or has an idea how to approach this problem?

Best regards,


Labels (1)
Tags (1)
0 Kudos
1 Reply

NXP TechSupport
NXP TechSupport

Hi Atis

to prevent mfg tool hanging when loading custom kernel it is necessary to

rebuild mfg tools firmware (files in /firmware folder) with new calibration settings

found from ddr test (put them in uboot/../mx6sabresd/mx6q_4x_mt41j128.cfg)

i.MX6/7 DDR Stress Test Tool V2.92 

using procedure in sect.6.2 Manufacturing Tool, MFGTool attached Yocto Guide

Best regards
Note: If this post answers your question, please click the Correct Answer button. Thank you!

0 Kudos