imx8mp add mipi display (splash screen) to uboot.

cancel
Showing results for 
Search instead for 
Did you mean: 

imx8mp add mipi display (splash screen) to uboot.

90 Views
dennis3
Contributor IV

Hello,

I'd like to add support for our mipi display for a splash screen during uboot.  I'm basing dts changes off the imx8mp-evk.dts file in <uboot-dir>/arch/arm/dts/ from the 10_2.6.0 code base.

From the evaluation board dts file, it seems one simply has to 

1) Add your custom panel

2) &lcdif1 { status="okay"; }

3) &mipi_dsi { status="okay"; <add port from dsi to your panel>; }

For me, steps 1 and 3 don't cause any problems but if I simply change lcdif1 from disabled to okay, uboot fails to boot.  The output is normal SPL output:

U-Boot SPL 2020.04-49489-g94eeddb0e5-dirty (Jun 08 2021 - 10:38:08 -0600)
Normal Boot
Trying to boot from BOOTROM
image offset 0x0, pagesize 0x200, ivt offset 0x0

And then the board simply just powers back off.

If I just leave lcdif1 status=disabled, uboot boots normally.  

So it appears I am missing some step to use the lcdif..  Can anyone suggest how to debug or find what is missing to allow proper boot with lcdif1 enabled?

Tags (4)
0 Kudos
2 Replies

59 Views
nxf46838
NXP TechSupport
NXP TechSupport
0 Kudos

42 Views
dennis3
Contributor IV

Thank you Aldo for this reference. 

I've gone through the changes in this patch and have verified my code base has all these changes in my board configuration and dts files.  Unfortunately, I haven't made any progress.  Same situation as before.

SPL loads and prints up through the "image offset" message but then there is no more output and the board powers off.  I'm still trying to find how to debug the problem.  

If I simply set status="disabled" in the lcdif1 block I can boot properly without a display.

0 Kudos