i.MX8M Mini MIPI DSI No HDMI Output

Showing results for 
Search instead for 
Did you mean: 

i.MX8M Mini MIPI DSI No HDMI Output

Contributor II

Hi All,

I am currently testing the i.MX8M Mini evaluation kit i.MX 8M Mini Evaluation Kit | NXP  and I'm having trouble with the MIPI HDMI output from the board. I successfully compiled both the yocto image and android 9.0 image and installed with the UUU tool with no issues. The issue is when I boot the image I get the NXP bootloader logo but after that the screen has no output and the display seems like it is not detecting the HDMI even though the HDMI is connected. My question is:

- Is there any other thing needed to output HDMI through the MIPI DSI adapter that the evaluation board comes with?

- Do I need to recompile image differently to get the HDMI output?


Cesar Hernandez

0 Kudos
3 Replies

NXP TechSupport
NXP TechSupport

Hi Cesar

one can try Demo Image also recommended to check with several hdmi panels

Linux Binary Demo Files - i.MX 8MMini EVK

One can check log, if linux driver gets EDID information from HDMI device.

Best regards
Note: If this post answers your question, please click the Correct Answer button. Thank you!

0 Kudos

Contributor II


I downloaded and tried the demo image with still no luck.

During boot the log outputs

-Boot 2018.03-imx_v2018.03_4.14.78_1.0.0_ga+g654088c (Nov 28 2018 - 19:15:55 +0000)

CPU: Freescale i.MX8MMQ rev1.0 1800 MHz (running at 1200 MHz)
CPU: Commercial temperature grade (0C to 95C) at 38C
Reset cause: POR
Model: FSL i.MX8MM EVK board
TCPC: Vendor ID [0x1fc9], Product ID [0x5110], Addr [I2C1 0x52]
Power supply on USB2
TCPC: Vendor ID [0x1fc9], Product ID [0x5110], Addr [I2C1 0x50]
Loading Environment from MMC... *** Warning - bad CRC, using default environment

Failed (-5)
No panel detected: default to MIPI2HDMI
Display: MIPI2HDMI (1920x1080)
Video: 1920x1080x24
In: serial
Out: serial
Err: serial

- ATF d6451cc
- U-Boot 2018.03-imx_v2018.03_4.14.78_1.0.0_ga+g654088c

Farther down the log it outputs this line:

[ 1.334686] ------------[ cut here ]------------
[ 1.334704] WARNING: CPU: 0 PID: 1 at /usr/src/kernel/drivers/gpu/drm/bridge/sec-dsim.c:1154 sec_mipi_dsim_check_pll_out+0x1a0/0x288
[ 1.334707] Modules linked in:
[ 1.334716] CPU: 0 PID: 1 Comm: swapper/0 Not tainted 4.14.78-imx_4.14.78_1.0.0_ga+g66620c3 #1
[ 1.334719] Hardware name: FSL i.MX8MM EVK board (DT)
[ 1.334722] task: ffff8000763b0000 task.stack: ffff000008078000
[ 1.334726] PC is at sec_mipi_dsim_check_pll_out+0x1a0/0x288
[ 1.334731] LR is at sec_mipi_dsim_check_pll_out+0x124/0x288
[ 1.334735] pc : [<ffff0000086b1620>] lr : [<ffff0000086b15a4>] pstate: 60000045
[ 1.334739] sp : ffff00000807b410

I have tried with 3 different monitors but still no success.

Also, attached is the full log from the bootup sequence for reference. Thanks.

0 Kudos

NXP TechSupport
NXP TechSupport

so hdmi works fine in uboot but not in linux, correct?

One can try workarounds provided on

Yocto release for i.MX 8MM - Boundary Devices 

Best regards

0 Kudos