how to get yocto toolchain for imx6q (Linux 5.4.47_2.2.0)

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

how to get yocto toolchain for imx6q (Linux 5.4.47_2.2.0)

2,616 Views
ttttttx
Contributor III

I am trying to download yocto resources for Linux 5.4.47_2.2.0 for imx6q-sabesd board . 

Because some resources have not been downloaded successfully during bitbake imx-image-full, I tried later:
bitbake core-image-base                               ---> ok
bitbake core-image-base -c populate_sdk     ---> failed
bitbake meta-toolchain                                   ---> failed

I found that I have successfully downloaded the kernel and uboot source code, I just want to have a cross-compiler. I will try to download other resources later.

The error message is almost like this:

| WARNING: exit code 1 from a shell command.
|
ERROR: Task (virtual:native:/home/linux/imx-yocto-bsp/sources/meta-clang/recipes-devtools/clang/clang_git.bb:do_compile) failed with exit code '1'
NOTE: Tasks Summary: Attempted 4030 tasks of which 4029 didn't need to be rerun and 1 failed.

Summary: 1 task failed:
virtual:native:/home/linux/imx-yocto-bsp/sources/meta-clang/recipes-devtools/clang/clang_git.bb:do_compile
Summary: There was 1 ERROR message shown, returning a non-zero exit code.

After this :
bitbake -c cleanall clang-native
bitbake -c cleanall clang

bitbake meta-toolchain    ------------------> failed 

Please check the attachment ( the file Linux 5.4.47_2.2.0.txt ) for detailed error information

We have been using gcc. Why is clang here? What should I do now? 

In addition, how to get  the official cross compiler out of the Yocto project ?

 

Tags (1)
0 Kudos
Reply
2 Replies

2,595 Views
igorpadykov
NXP Employee
NXP Employee

Hi raotianxiang

 

one can try to follow sect.2.1.1 How to build and load Kernel in standalone environment,

sect.3.1.1 How to build U-Boot in standalone environment    i.MX Porting Guide

or third party tutorial

https://developer.toradex.com/knowledge-base/build-u-boot-and-linux-kernel-from-source-code#Compilat...

 

Best regards
igor

0 Kudos
Reply

2,574 Views
ttttttx
Contributor III

Thank you for your answers. 

But I think this is only a temporary solution. Because I use the official guide IMX_YOCTO_PROJECT_USERS_GUIDE.pdf to obtain yocto resources, the current problem should not arise. I have tried bitbake imx-image-full or bitbake imx-image-full -c populate_sdk or bitbake meta-toolchain or meta-toolchain-qt5 after cleanall, but no success :

linux@ubuntu:~/imx-yocto-bsp/build-xwayland-imx6qsabresd$ bitbake imx-image-full -c populate_sdk -k
...
Summary: 3 tasks failed:
virtual:native:/home/linux/imx-yocto-bsp/sources/meta-clang/recipes-devtools/clang/clang_git.bb:do_compile
/home/linux/imx-yocto-bsp/sources/meta-imx/meta-bsp/recipes-support/opencv/opencv_4.2.0.imx.bb:do_compile
/home/linux/imx-yocto-bsp/sources/meta-qt5/recipes-qt/qt5/qtbase_git.bb:do_compile

Please see the attached file.

I am not sure if this third-party compiler is convenient for the compilation of QT programs. I still need all the official resources, please help me, thank you very much.