git.freescale.com down

cancel
Showing results for 
Search instead for 
Did you mean: 

git.freescale.com down

Jump to solution
6,396 Views
Contributor I

We noticed this morning our builds started failing. Looks like attempting to clone firmware-imx is failing.

When I try to clone the repo independent of a yocto build I see the following output:

git clone git://git.freescale.com/imx/imx-firmware.git
Cloning into 'imx-firmware'...
fatal: unable to connect to git.freescale.com:
git.freescale.com[0: 192.88.156.202]: errno=Connection refused

Are there mirrors we could using for this repo?

Labels (1)
1 Solution
1,178 Views
NXP TechSupport
NXP TechSupport

Hello Adam Bader, Diego Perez, and Alex Movitz, 

The git://git.freescale.com repository was replaced by git://github.com/NXP/imx-firmware

Some recipes may still refer to the old repository so please replace them on the recipes where you are experiencing issues.

Regards,

View solution in original post

0 Kudos
27 Replies
1,073 Views
Contributor III

I ran into this issue trying to sync for an Android 8 build.  I was able to get around it with the following.

git config --global url."git://github.com/NXP/".insteadOf git://git.freescale.com/proprietary/

Update:

The repo sync completed but the imx-firmware directory was empty.  I had to manually clone to continue the build.

1,073 Views
Contributor II

I'm disappointed at this situation.

Your documentation for old revision something like YOCTO 3.14.38 still advise to use git.freescale.com.

I thought this momentary trouble in git repo. and I cannot found any announcement about new repository, and I almost drop my project.

this is not good.

0 Kudos
1,073 Views
Contributor III

Even we at Power Progress Community we are confused...

As 3 years ago we have forked git://git.freescale.com/ppc/sdk/u-boot.git repository in our https://gitlab.com/power-progress-community/oshw-powerpc-notebook/freescale.com-ppc-u-boot

that contain our patches to make working the Video Card with T2080RDB, our question is now from which repository we need to re-base our fork ?

0 Kudos
1,073 Views
Contributor I

We are also encountering a failed build for cl-som-imx7, would appreciate your assistance locating:

http://git.freescale.com/git/cgit.cgi/imx/linux-imx.git/snapshot/linux-imx-rel_imx_4.9.x_1.0.0_ga.ta... 

searched the 3 repos you have suggested, no luck there.

0 Kudos
1,073 Views
Contributor III

We have searched the old repository git://git.freescale.com/ppc/sdk/u-boot.git under new NXP git repositories  NXP · GitHub  but it dosen't exists. We have even searched under Code Aurora git repositories  .

Where are now NXP forks of Open Source u-boot ?  They should be Open Source. In particular we need for our NXP T2080 Power Architecture Open Hardware Notebook Design

Thanks

0 Kudos
1,073 Views
Contributor I

You've moved one minor repo, master branch and no sdk branches to github, and deleted an actively used server.

It might be better if you restored git.freescale.com, removed your linux-firmware repo, and duplicated it on github NXP.

There are literally hundreds of repos on git.freescale.com.


We are in the middle of going to production, and this reflects days of work recreating git.freescale.com for just our needs.


Many other products and SDK's are broken with no way to recover the correct content. Multiple versions are buried in tar files, and extracting the complete version history is at best a guess.

For c293 we need these 93 repos, along with recipe updates. Safe to say all of qoriq is broken.

Could you please move these to github NXP and update the recipe files?

meta-cyphre-c29x/scripts/fsl-setup-env:SOURCE_MIRROR_URL ?= "http://git.freescale.com/source/"
meta-cgl/meta-cgl-fsl-ppc/recipes-kernel/linux/linux-qoriq-cgl-prt_3.12.bb:SRC_URI += "git://git.freescale.com/ppc/sdk/linux.git;nobranch=1 \
meta-nxp-npi-1703/recipes-bsp/rcw/ls2-rcw_git.bbappend:SRC_URI = "git://git.freescale.com/ppc/sdk/ls2-rcw.git;nobranch=1"
meta-nxp-npi-1703/recipes-bsp/rcw/rcw_git.bbappend:SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;nobranch=1"
meta-nxp-npi-1703/recipes-bsp/u-boot/u-boot-qoriq_2016.09.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;nobranch=1"
meta-nxp-npi-1703/recipes-bsp/pkc-firmware/pkc-firmware_git.bbappend:SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-firmware.git;nobranch=1"
meta-nxp-npi-1703/recipes-bsp/ppa/ppa_git.bbappend:SRC_URI = "git://git.freescale.com/ppc/sdk/ppa-generic.git;nobranch=1"
meta-nxp-npi-1703/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/engine-pfe-bin.git;nobranch=1"
meta-nxp-npi-1703/recipes-dpaa/fm-ucode/fm-ucode_git.bbappend:SRC_URI = "git://git.freescale.com/ppc/sdk/fm-ucode.git;nobranch=1"
meta-nxp-npi-1703/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bbappend:SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa/usdpaa-apps.git;nobranch=1"
meta-nxp-npi-1703/recipes-dpaa/fmc/fmc_git.bbappend:SRC_URI = "git://git.freescale.com/ppc/sdk/fmc.git;branch=sdk-v2.0.x"
meta-nxp-npi-1703/recipes-dpaa/usdpaa/usdpaa_git.bbappend:SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa.git;nobranch=1"
meta-nxp-npi-1703/recipes-binary/satrace/satrace_1.0.0.163901.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/satrace.git;nobranch=1"
meta-nxp-npi-1703/recipes-kernel/scatter-gather/scatter-gather_git.bbappend:SRC_URI = "git://git.freescale.com/ppc/sdk/scatter-gather.git;nobranch=1"
meta-nxp-npi-1703/recipes-kernel/linux/linux-qoriq_4.1.bbappend:SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;nobranch=1"
meta-nxp-npi-1703/recipes-kernel/pkc-host/pkc-host_git.bbappend:SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-host.git;nobranch=1"
meta-nxp-npi-1703/.git/config:    url = git://git.freescale.com/yocto/meta-nxp-npi
meta-nxp-npi-1703/recipes-devtools/qemu/qemu_qoriq.bbappend:SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;nobranch=1"
meta-nxp-npi-1703/recipes-devtools/cst/cst_git.bbappend:SRC_URI = "git://git.freescale.com/ppc/sdk/cst.git;nobranch=1"
meta-nxp-npi-1703/recipes-extended/dpdk/dpdk-extras_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/dpdk-extras.git;nobranch=1"
meta-nxp-npi-1703/recipes-extended/dpdk/dpdk_16.07.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/dpdk.git;nobranch=1 \
meta-nxp-npi-1703/recipes-extended/odp/odp.inc:git://git.freescale.com/ppc/sdk/odp.git;nobranch=1 \
meta-nxp-npi-1703/recipes-extended/odp/odp.inc:git://git.freescale.com/ppc/sdk/qbman_userspace.git;nobranch=1;name=qbman;destsuffix=git/platform/linux-dpaa2/flib/qbman \
meta-nxp-npi-1703/recipes-extended/odp/odp.inc:git://git.freescale.com/ppc/sdk/flib.git;nobranch=1;name=rta;destsuffix=git/platform/linux-dpaa2/flib/rta \
meta-nxp-npi-1703/recipes-extended/skmm-ep/skmm-ep_git.xxx:SRC_URI = "git://git.freescale.com/ppc/sdk/skmm-ep.git;nobranch=1 \
meta-nxp-npi-1703/recipes-extended/skmm-ep/skmm-ep_git.bbappend:SRC_URI = "git://git.freescale.com/ppc/sdk/skmm-ep.git;nobranch=1 \
meta-nxp-npi-1703/recipes-extended/ovs-dpdk/ovs-dpdk_0.1.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/ovs-dpdk.git;nobranch=1"
meta-nxp-npi-1703/README:4. $ git clone git://git.freescale.com/yocto/meta-nxp-npi.git -b jethro-sdk-v2.0-ga-1703 meta-nxp-npi-ga
meta-nxp-npi-1703/recipes-dpaa2/gpp-aioptool/gpp-aioptool_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/gpp-aioptool.git;nobranch=1"
meta-nxp-npi-1703/recipes-dpaa2/dpl-examples/dpl-examples_git.bbappend:SRC_URI = "git://git.freescale.com/ppc/sdk/dpl-examples.git;nobranch=1"
meta-nxp-npi-1703/recipes-dpaa2/aiopsl/aiopsl_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/aiopsl.git;nobranch=1"
meta-nxp-npi-1703/recipes-dpaa2/restool/restool_git.bbappend:SRC_URI = "git://git.freescale.com/ppc/sdk/restool.git;nobranch=1"
meta-nxp-npi-1703/recipes-dpaa2/mc/management-complex_10.1.2.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/mc-binary.git;nobranch=1"
meta-nxp-npi-1703/recipes-dpaa2/dce/dce_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/dce.git;nobranch=1"
meta-freescale/recipes-bsp/apptrk/apptrk_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/apptrk.git;branch=sdk-v2.0.x \
meta-freescale/recipes-bsp/flash-image/flash-map-cfg_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/flashmap.git;branch=sdk-v2.0.x"
meta-freescale/recipes-bsp/qe-ucode/qe-ucode_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/qe-ucode.git;branch=sdk-v2.0.x"
meta-freescale/recipes-bsp/rcw/rcw_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=sdk-v2.0.x"
meta-freescale/recipes-bsp/rcw/ls2-rcw_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/ls2-rcw.git;branch=sdk-v2.0.x"
meta-freescale/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH}"
meta-freescale/recipes-bsp/u-boot/u-boot-imx_2015.04.bb:SRC_URI = "git://git.freescale.com/imx/uboot-imx.git;protocol=git;branch=${SRCBRANCH}"
meta-freescale/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH} \
meta-freescale/recipes-bsp/ls2-phy/ls2-phy_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/ls2-phy.git;branch=sdk-v2.0.x"
meta-freescale/recipes-bsp/pkc-firmware/pkc-firmware_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-firmware.git;branch=sdk-v2.0.x"
meta-freescale/recipes-bsp/ppa/ppa_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/ls1043-ppa.git;branch=sdk-v2.0.x \
meta-freescale/recipes-bsp/fsl-tlu/fsl-tlu_1.0.0.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/fsl-tlu.git;branch=master"
meta-freescale/recipes-bsp/boot-format/boot-format_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/boot-format.git;nobranch=1 \
meta-freescale/scripts/fsl-setup-env:SOURCE_MIRROR_URL ?= "http://git.freescale.com/source/"
meta-freescale/recipes-dpaa/flib/flib_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/flib.git;branch=sdk-v2.0.x"
meta-freescale/recipes-dpaa/fm-ucode/fm-ucode_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/fm-ucode.git;branch=sdk-v2.0.x"
meta-freescale/recipes-dpaa/eth-config/eth-config_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/eth-config.git;branch=sdk-v2.0.x"
meta-freescale/recipes-dpaa/dpa-offload/dpa-offload_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa/dpa-offload.git;branch=sdk-v2.0.x"
meta-freescale/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa/usdpaa-apps.git;branch=sdk-v2.0.x"
meta-freescale/recipes-dpaa/fmc/fmc_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/fmc.git;branch=sdk-v1.9.x"
meta-freescale/recipes-dpaa/usdpaa/usdpaa_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa.git;branch=sdk-v2.0.x"
meta-freescale/recipes-dpaa/fmlib/fmlib_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/fmlib.git;branch=sdk-v2.0.x"
meta-freescale/recipes-kernel/scatter-gather/scatter-gather_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/scatter-gather.git;branch=master"
meta-freescale/recipes-kernel/ceetm/ceetm_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/ceetm.git;branch=sdk-v2.0.x"
meta-freescale/recipes-kernel/ls-debug/ls-debug_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/ls-dbg.git;branch=master"
meta-freescale/recipes-kernel/ar/ar_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/auto-resp.git;branch=sdk-v2.0.x"
meta-freescale/recipes-kernel/uio-seville/uio-seville_0.1.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/l2switch-uio.git;branch=sdk-v2.0.x"
meta-freescale/recipes-kernel/skmm-host/skmm-host_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/skmm-host.git;branch=sdk-v2.0.x"
meta-freescale/recipes-kernel/linux/linux-imx.inc:SRC_URI = "git://git.freescale.com/imx/linux-2.6-imx.git;branch=${SRCBRANCH} \
meta-freescale/recipes-kernel/linux/linux-qoriq_4.1.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;branch=sdk-v2.0.x"
meta-freescale/recipes-kernel/asf/asf_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;branch=sdk-v2.0.x"
meta-freescale/recipes-kernel/perf-qoriq/perf-qoriq_0.8.2.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/qoriq-perf.git;branch=master"
meta-freescale/recipes-kernel/pkc-host/pkc-host_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-host.git;branch=sdk-v2.0.x"
meta-freescale/conf/layer.conf:QORIQ_MIRROR ?= "http://git.freescale.com/source/"
meta-freescale/.git/config:    url = git://git.freescale.com/yocto/meta-freescale
meta-freescale/recipes-virtualization/hypervisor/hypervisor_git.bb:    git://git.freescale.com/ppc/sdk/hypervisor/hypervisor.git;name=hypervisor;branch=sdk-v2.0.x \
meta-freescale/recipes-virtualization/hypervisor/hypervisor_git.bb:    git://git.freescale.com/ppc/sdk/hypervisor/kconfig.git;name=kconfig;destsuffix=git/kconfig;branch=sdk-v2.0.x \
meta-freescale/recipes-virtualization/hypervisor/hypervisor_git.bb:    git://git.freescale.com/ppc/sdk/hypervisor/libos.git;name=libos;destsuffix=git/libos;branch=sdk-v2.0.x \
meta-freescale/recipes-virtualization/hypervisor/hypervisor_git.bb:    git://git.freescale.com/ppc/sdk/hypertrk.git;name=hypertrk;destsuffix=git/hypertrk;branch=sdk-v2.0.x \
meta-freescale/recipes-virtualization/hv-cfg/hv-cfg_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/hv-cfg.git;branch=sdk-v2.0.x"
meta-freescale/recipes-virtualization/mux-server/mux-server_1.02.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/hypervisor/mux_server.git;branch=master"
meta-freescale/SCR/imx/SCR-3.14.38-6QP_ga.txt:Release Location:          git.freescale.com branch imx_3.14.38_6qp_ga
meta-freescale/SCR/imx/SCR-3.14.38-6QP_ga.txt:Release Location:          git.freescale.com branch imx_v2015.04_3.14.38_6qp_ga
meta-freescale/SCR/imx/SCR-3.14.38-6UL_ga.txt:Release Location:          git.freescale.com branch imx_3.14.38_6ul_ga
meta-freescale/SCR/imx/SCR-3.14.38-6UL_ga.txt:Release Location:          git.freescale.com branch imx_v2015.04_3.14.38_6ul_ga
meta-freescale/recipes-devtools/gdb/gdb-fsl.inc:SRC_URI = "http://git.freescale.com/git/cgit.cgi/ppc/sdk/gdb.git/snapshot/gdb-fsl-sdk-v2.0.tar.bz2"
meta-freescale/recipes-devtools/qemu/qemu_qoriq.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;branch=sdk-v2.0.x"
meta-freescale/recipes-devtools/cst/cst_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/cst.git;branch=sdk-v2.0.x"
meta-freescale/recipes-extended/hyperrelay/hyperrelay_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/hyperrelay.git;branch=sdk-v2.0.x"
meta-freescale/recipes-extended/ipc-ust/ipc.inc:SRC_URI = "git://git.freescale.com/ppc/sdk/ipc.git;branch=sdk-v2.0.x"
meta-freescale/recipes-extended/web-sysmon/web-sysmon_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/web-sysmon-dev.git;nobranch=1"
meta-freescale/recipes-extended/cantest/cantest_1.0.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/cantest.git;branch=sdk-v2.0.x"
meta-freescale/recipes-extended/skmm-ep/skmm-ep_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/skmm-ep.git;branch=sdk-v2.0.x \
meta-freescale/recipes-extended/fsl-pme/fsl-pme_1.0.3.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/fsl-pme.git;branch=sdk-v2.0.x"
meta-freescale/recipes-extended/libppc/libppc_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/libppc.git;branch=sdk-v2.0.x"
meta-freescale/recipes-extended/pme-tools/pme-tools_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/pme_tools.git;branch=sdk-v2.0.x \
meta-freescale/recipes-dpaa2/dpl-examples/dpl-examples_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/dpl-examples.git;branch=sdk-v2.0.x"
meta-freescale/recipes-dpaa2/restool/restool_git.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/restool.git;branch=sdk-v2.0.x"
meta-freescale/recipes-dpaa2/mc/management-complex_0.8.4.bb:SRC_URI = "git://git.freescale.com/ppc/sdk/mc-binary.git;branch=sdk-v2.0.x"

0 Kudos
1,128 Views
Contributor I

Is this ever going to come back online?

Why would a major corporation alienate their current and potential future customers by shutting down a simple git repository?

If you have to ask, I'm essentially looking for the same repository as the previous poster, which I don't see a response to, but, I assume you have the original set of repositories, so I don't understand why you can't just bring them all back online, even if it's at another URL.

0 Kudos
1,128 Views
NXP TechSupport
NXP TechSupport

Hello Brian Webb,

My apologies for the inconveniences caused by this change.

There are no plans to bring git.freescale.com back online, all content was migrated to either one of these repositories:

github.com/NXP

github.com/NXPMicro

https://source.codeaurora.org/external/imx/

It’s cumbersome, but please try changing the repositories as George Refseth to work around this issue.

Regards,

1,073 Views
Contributor IV

Hi gusarambula

It has some fail to download firmware-imx_5.4.bb  (base on krogoth_4.1.y")  (4.1.15_2.1.0 BSP)

I had build code in Y2018.

I upload to GDriver

firmware-imx.tar.bz2 - Google Drive 

firmware-imx include more bin file.

BRCM , VPU , EPD , SDMA bin file

You can see firmware-imx/1_5.4-r0/deploy-rpms/cortexa7hf_neon_mx6ul file name list

pastedImage_2.png

0 Kudos
1,075 Views
Contributor I

Could you at least replace the page with something that informs people of the new locations of the repositories?

Like it or not, your git repository is used all over the place, even in printed literature. Unless you're going out of business I just can't imagine why you would shut it down.

0 Kudos
1,128 Views
Contributor II

In our case, we needed to migrate the meta-fsl-bsp-release repository within our submodule. Once we replaced this, all recursive submodules also worked.

```
[submodule "meta-fsl-bsp-release"]
 path = sources/meta-fsl-bsp-release
- url = git://git.freescale.com/imx/meta-fsl-bsp-release
+ url = https://source.codeaurora.org/external/imx/meta-fsl-bsp-release
```

As an aside, this was a forced migration that we and our partners/customers are not happy about. 

0 Kudos
1,128 Views
Contributor II

Even after migrating the submodule repository, we still have a major issue. There are a lot of recipes which still rely entirely on the git.freescale.com repository to function. All of these recipes will need to change in the new repositories to reflect that git.freescale.com is no longer up.

```
user@facb926d01b2:~/src/fsl-release-bsp$ grep -rin 'git.freescale.com' --include=*.bb
sources/meta-fsl-bsp-release/imx/meta-bsp/recipes-bsp/firmware-imx/firmware-imx_6.0.bb:11:IMX_FIRMWARE_SRC ?= "git://git.freescale.com/proprietary/imx-firmware.git;protocol=git"
sources/meta-freescale/recipes-kernel/kernel-modules/kernel-module-uio-seville_0.1.bb:5:SRC_URI = "git://git.freescale.com/ppc/sdk/l2switch-uio.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-kernel/kernel-modules/kernel-module-scatter-gather_git.bb:7:SRC_URI = "git://git.freescale.com/ppc/sdk/scatter-gather.git;branch=master"
sources/meta-freescale/recipes-kernel/kernel-modules/kernel-module-perf-qoriq_0.8.2.bb:5:SRC_URI = "git://git.freescale.com/ppc/sdk/qoriq-perf.git;branch=master"
sources/meta-freescale/recipes-kernel/kernel-modules/kernel-module-ar_git.bb:7:SRC_URI = "git://git.freescale.com/ppc/sdk/auto-resp.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-kernel/kernel-modules/kernel-module-ls-debug_git.bb:10:SRC_URI = "git://git.freescale.com/ppc/sdk/ls-dbg.git;branch=master"
sources/meta-freescale/recipes-kernel/ceetm/ceetm_git.bb:5:SRC_URI = "git://git.freescale.com/ppc/sdk/ceetm.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-kernel/pkc-host/pkc-host_git.bb:13:SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-host.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-kernel/linux/linux-qoriq_4.1.bb:10:SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;nobranch=1 \
sources/meta-freescale/recipes-kernel/skmm-host/skmm-host_git.bb:8:SRC_URI = "git://git.freescale.com/ppc/sdk/skmm-host.git;branch=sdk-v2.0.x"
sources/meta-freescale/dynamic-layers/networking-layer/recipes-kernel/asf/asf_git.bb:6:SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;branch=sdk-v2.0.x"
sources/meta-freescale/dynamic-layers/openembedded-layer/recipes-support/web-sysmon/web-sysmon_git.bb:19:SRC_URI = "git://git.freescale.com/ppc/sdk/web-sysmon-dev.git;nobranch=1"
sources/meta-freescale/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb:9:SRC_URI = "git://git.freescale.com/ppc/sdk/fmc.git;branch=sdk-v2.0.x"
sources/meta-freescale/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb:15:SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa/usdpaa-apps.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-devtools/qemu/qemu-qoriq_git.bb:28:SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-devtools/cst/cst_git.bb:13:SRC_URI = "git://git.freescale.com/ppc/sdk/cst.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-extended/pme-tools/pme-tools_git.bb:5:SRC_URI = "git://git.freescale.com/ppc/sdk/pme_tools.git;branch=sdk-v2.0.x \
sources/meta-freescale/recipes-extended/fsl-pme/fsl-pme_1.0.3.bb:8:SRC_URI = "git://git.freescale.com/ppc/sdk/fsl-pme.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-extended/skmm-ep/skmm-ep_git.bb:10:SRC_URI = "git://git.freescale.com/ppc/sdk/skmm-ep.git;branch=sdk-v2.0.x \
sources/meta-freescale/recipes-extended/hyperrelay/hyperrelay_git.bb:5:SRC_URI = "git://git.freescale.com/ppc/sdk/hyperrelay.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-extended/ipc-ust/ipc-ust_git.bb:6:SRC_URI = "git://git.freescale.com/ppc/sdk/ipc.git;branch=sdk-v2.0.x \
sources/meta-freescale/recipes-extended/cantest/cantest_1.0.bb:5:SRC_URI = "git://git.freescale.com/ppc/sdk/cantest.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-dpaa2/management-complex/management-complex_0.8.4.bb:9:SRC_URI = "git://git.freescale.com/ppc/sdk/mc-binary.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-dpaa2/restool/restool_git.bb:7:SRC_URI = "git://git.freescale.com/ppc/sdk/restool.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-dpaa2/dpl-examples/dpl-examples_git.bb:9:SRC_URI = "git://git.freescale.com/ppc/sdk/dpl-examples.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-bsp/pkc-firmware/pkc-firmware_git.bb:13:SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-firmware.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-bsp/fsl-tlu/fsl-tlu_1.0.0.bb:8:SRC_URI = "git://git.freescale.com/ppc/sdk/fsl-tlu.git;branch=master"
sources/meta-freescale/recipes-bsp/ppa/ppa_git.bb:9:SRC_URI = "git://git.freescale.com/ppc/sdk/ppa-generic.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-bsp/u-boot/u-boot-qoriq_2016.09.bb:21:SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;nobranch=1 \
sources/meta-freescale/recipes-bsp/u-boot/u-boot-imx_2016.03.bb:12:SRC_URI = "git://git.freescale.com/imx/uboot-imx.git;protocol=git;branch=${SRCBRANCH}"
sources/meta-freescale/recipes-bsp/boot-format/boot-format_git.bb:6:SRC_URI = "git://git.freescale.com/ppc/sdk/boot-format.git;nobranch=1 \
sources/meta-freescale/recipes-bsp/ls2-phy/ls2-phy_git.bb:7:SRC_URI = "git://git.freescale.com/ppc/sdk/ls2-phy.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-bsp/qe-ucode/qe-ucode_git.bb:8:SRC_URI = "git://git.freescale.com/ppc/sdk/qe-ucode.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-bsp/apptrk/apptrk_git.bb:10:SRC_URI = "git://git.freescale.com/ppc/sdk/apptrk.git;branch=sdk-v2.0.x \
sources/meta-freescale/recipes-bsp/rcw/rcw_git.bb:10:SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-bsp/rcw/ls2-rcw_git.bb:11:SRC_URI = "git://git.freescale.com/ppc/sdk/ls2-rcw.git;nobranch=1"
sources/meta-freescale/recipes-virtualization/hypervisor/hypervisor_git.bb:14: git://git.freescale.com/ppc/sdk/hypervisor/hypervisor.git;name=hypervisor;branch=sdk-v2.0.x \
sources/meta-freescale/recipes-virtualization/hypervisor/hypervisor_git.bb:15: git://git.freescale.com/ppc/sdk/hypervisor/kconfig.git;name=kconfig;destsuffix=git/kconfig;branch=sdk-v2.0.x \
sources/meta-freescale/recipes-virtualization/hypervisor/hypervisor_git.bb:16: git://git.freescale.com/ppc/sdk/hypervisor/libos.git;name=libos;destsuffix=git/libos;branch=sdk-v2.0.x \
sources/meta-freescale/recipes-virtualization/hypervisor/hypervisor_git.bb:18: git://git.freescale.com/ppc/sdk/hypertrk.git;name=hypertrk;destsuffix=git/hypertrk;branch=sdk-v2.0.x \
sources/meta-freescale/recipes-virtualization/hv-cfg/hv-cfg_git.bb:21:SRC_URI = "git://git.freescale.com/ppc/sdk/hv-cfg.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-virtualization/mux-server/mux-server_1.02.bb:6:SRC_URI = "git://git.freescale.com/ppc/sdk/hypervisor/mux_server.git;branch=master \
sources/meta-freescale/recipes-dpaa/eth-config/eth-config_git.bb:8:SRC_URI = "git://git.freescale.com/ppc/sdk/eth-config.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-dpaa/fm-ucode/fm-ucode_git.bb:10:SRC_URI = "git://git.freescale.com/ppc/sdk/fm-ucode.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-dpaa/dpa-offload/dpa-offload_git.bb:15:SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa/dpa-offload.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-dpaa/fmlib/fmlib_git.bb:8:SRC_URI = "git://git.freescale.com/ppc/sdk/fmlib.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-dpaa/flib/flib_git.bb:6:SRC_URI = "git://git.freescale.com/ppc/sdk/flib.git;branch=sdk-v2.0.x"
sources/meta-freescale/recipes-dpaa/usdpaa/usdpaa_git.bb:10:SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa.git;branch=sdk-v2.0.x"
```

gusarambula At this point, we are very frustrated with this forced migration and need git.freescale.com to come back up so we and our partners can continue operating. This is affecting every NXP customer using i.MX chips. This is completely unacceptable business practices.

1,128 Views
Contributor I

Having a similar problem while building a release for Compulab CL-SOM-iMX6:

repo init -u git://git.freescale.com/imx/fsl-arm-yocto-bsp.git -b imx-morty -m imx-4.1.33-7ulp_beta.xml

[…]

Downloading manifest from git://git.freescale.com/imx/fsl-arm-yocto-bsp.git
manifests:
fatal: unable to connect to git.freescale.com:
git.freescale.com[0: 192.88.156.202]: errno=Connection refused

- Dave

gusarambula

0 Kudos
1,128 Views
Contributor I

We are using git://git.freescale.com/imx, and can't see that it can be replaced by git://github.com/NXP/imx-firmware, please elaborate.

<project remote="fsl-release" name="meta-fsl-bsp-release" path="sources/meta-fsl-bsp-release" revision="jethro_4.1.15-1.0.0_ga" >

0 Kudos
1,128 Views
Contributor I

Changing

<remote fetch="git://git.freescale.com/imx" name="fsl-release" />

to this

 <remote fetch="https://source.codeaurora.org/external/imx" name="fsl-release" />

In our repo manifest and using the codeaurora mirror fixed our problems.

Best regards,
George

1,128 Views
NXP TechSupport
NXP TechSupport

Hello George,

Thank you for posting this workaround. I'm sure it will help many Community Users.

As reference, the content from the freescale.git repository were moved to the following repositories:

github.com/NXP

github.com/NXPMicro

https://source.codeaurora.org/external/imx/

So it may happen that a specific recipe requires one of the two first repositories as well.

Regards,

0 Kudos
1,179 Views
NXP TechSupport
NXP TechSupport

Hello Adam Bader, Diego Perez, and Alex Movitz, 

The git://git.freescale.com repository was replaced by git://github.com/NXP/imx-firmware

Some recipes may still refer to the old repository so please replace them on the recipes where you are experiencing issues.

Regards,

View solution in original post

0 Kudos
1,128 Views
Contributor II

Hi gusarambula,

Could you pls get the updated link for this from NXP.

IMX_MIRROR ?= http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/      <- Obsolete link

Thanks,

0 Kudos
1,128 Views
Contributor I

It does not appear that everything from the git://git.freescale.com repository was properly migrated to git://github.com/NXP/imx-firmware (or any other repo I see under user NXP), as now I'm getting the following build errors:

ERROR: linux-compulab-4.1.15-r0 do_fetch: Fetcher failure: Unable to resolve 'rel_imx_4.1.15_1.2.0_ga' in upstream git repository in git ls-remote output for github.com/NXP/imx-firmware.git
ERROR: linux-compulab-4.1.15-r0 do_fetch: Function failed: base_do_fetch

The original repo, now unavailable, I believe was pulled from git://git.freescale.com/imx/fsl-arm-yocto-bsp.git
The current failure, however, is failing to pull what was previously housed in git://git.freescale.com/imx/linux-imx.git

Can you assist? This is blocking all new builds, which means new releases for our customers.

Thanks,

Whitaker

0 Kudos
1,128 Views
NXP TechSupport
NXP TechSupport

Hello Whitaker,

My apologies. Most of what was on git.freescale.com should be now on github.com/NXP have you tried with this repository (instead of the imx-firmware)?

And also, which BSP Release are you using? That would help us see which recipes seem affected. If you have not sync the repos in a while it could help to sync them as some recipes might have been updated.

Regards,

0 Kudos