Wrong confidence score Yolov8 on NPU i.MX 8M Plus

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Wrong confidence score Yolov8 on NPU i.MX 8M Plus

261 Views
simoberny
Contributor III

Hi,

I've been successfully using yolov5 on NPU for a while now.
I tried to switch to Yolov8, but for now with partial success.

OS: Yocto Kirkstone, Kernel 5.15.71

Hardware: i.MX 8M Plus

With both networks my procedure is as follows:

  • Training with the Yolo tool on dataset created with Roboflow
  • Exporting the .pt (Pytorch) to .pb (TF GraphDef) using the export tool integrated in the two versions of Yolo
  • Convert .pb to .tflite using NXP eIQ Portal tool using quantization on input.

In the case of Yolov5 the inference works perfectly and I can get 18+ FPS using an input of 320x320.

In the case of Yolov8 instead (with the necessary adjustments for inference, row/col inversion etc...), I obtain the bounding boxes correctly, but with a confidence score always equal and greater than 1.

Is there anyone who has already seen this problem or anyone who has already worked successfully with this type of network?

 

Thanks in advance,

Best regards

0 Kudos
2 Replies

25 Views
HME15769
Contributor II

@simoberny 
Belatedly, I tried the export feature of the ultralytics package and obtained successful results.
However, the inference speed was still slow, even on the NPU.
https://docs.ultralytics.com/modes/export/

@JosephAtNXP 
Don't bother answering if you don't understand.

0 Kudos

233 Views
JosephAtNXP
NXP TechSupport
NXP TechSupport

Hi,

Thank you for your interest in NXP Semiconductor products,

There are improves in different model executions when updating BSP, this would worth a try;

Also, the two models probably work with different pytorch versions and they're updated in some releases.

Could you try with latest BSP available?

Regards

0 Kudos