Where can I get an i.MX6 toolchain to build 5.15.71

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Where can I get an i.MX6 toolchain to build 5.15.71

507 Views
michaelworster
Contributor IV

I have a product using the i.MX6DL processor which is running off an older NXP supported kernel (4.1.15).

In order to build this kernel code I start by sourcing a bash script, which I'm pretty sure came from old Freescale instructions. The command is:

 

 source environment-setup-cortexa9hf-neon-poky-linux-gnueabi

 

After this it's possible to run:

 

make menuconfig
make zImage LOADADDR=0x10008000

 



and end with a bootable kernel image for the i.MX6DL. When i follow these steps now I get:

 

arch/arm/mach-at91/pm_suspend.S: Assembler messages:
arch/arm/mach-at91/pm_suspend.S:1086: Error: garbage following instruction -- `ldr tmp1,=0x00020010UL'
make[1]: *** [scripts/Makefile.build:391: arch/arm/mach-at91/pm_suspend.o] Error 1
make: *** [Makefile:1898: arch/arm/mach-at91] Error 2

 

 

Is this not the correct way to build on the newer NXP kernels? is this no longer the supported toolchain?

What is the proper way to build lf-5.15.y from scratch (not via bitbake) for the i.MX6DL SABER board?

Labels (3)
0 Kudos
Reply
1 Reply

459 Views
brian14
NXP TechSupport
NXP TechSupport

Hi @michaelworster

Unfortunately, for our newest BSP's, you will need to use The Yocto Project with the bitbake commands to generate the toolchain, after you get this toolchain, you can build using your described method.

I hope this information will be helpful. 

Have a great day!

0 Kudos
Reply