Problem!!! On mx27ads ref board, the USB device has not lighted after inserted to the USB slot.

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem!!! On mx27ads ref board, the USB device has not lighted after inserted to the USB slot.

1,168 Views
charli
Contributor I
Dear Sir/Madam,
 
I'am now using my board -- reference mx27ads board labeled rev2.6 with Freescale arm 2.6.19.2 linux to run my wirless USB card.  The card run normally under other OS with other platform,  but it cannot be lighted on under my board. I've test a USB storage card, the result is same. So, I don't know where I need to do more configurations, does it on software -- kernel or on hardware -- my board switch and so on?
 
The development status of my project is now more and more urgent because I've delayed the project without a correct way to solve the problem.
 
Could you give me a suggestion or solution?
 
I'm looking forward to your reply very anxiously.
 
 
Yours Sincerely,
 
Charles
0 Kudos
1 Reply

298 Views
aurelihein
Contributor I
hello charles,
You have to look into your kernel's configuration, to enable the USB part...
In LTIB check "configure the kernel" exit and save your new configuration . . .
Afterward the linux kernel configuration appear, go into "device drivers">"USB support"
Enable as much things as you need.
Be sure that "EHCI HCD USB2.0" | "support for ARC controller" | "Support for Host1" port on ARC controller" |"USB mass storage support" |  are built-in (the star symbol).
If you ever try to use the host 2 you have to check if you are not using your pins for another function, because a lot of things are multiplexed . . .
exit and save and flash your board with the new kernel
with the host 1 enable you should be able to mount a usb mass storage on the USB Host 1 FS port...
enjoy
good luck
aurelien

0 Kudos