Not able to set Bootanimation for i.MX8m mini using Android 9

Showing results for 
Search instead for 
Did you mean: 

Not able to set Bootanimation for i.MX8m mini using Android 9

Contributor I


I am having  i.MX 8M Mini EVK and have flashed Android 9 latest version 2.3.0 from NXP site 

"android_p9.0.0_2.3.0_image_8mmevk.tar.gz" on SD card using UUU, i could use Android 9 on it, also i can download custom App using ADB from Android Studio using Windows and Linux.

My next task is to set Bootanimation with custom images and logo. Currently i can see Android boot animation which is the default one. Looking at many videos i copied the ( downloaded from NXP forum, to start with, as i can change that later to my own ) into /_/system/media/ and also to /data/local inserting SD card to linux PC.

It gave no change.

Later when i explored, i noticed that the location i copied the file, i could not see the when i use ADB shell command to get into device. Later using boot animation is not working i followed the steps there, i could push the zip file to SD card, but failed to mount the /system into write mode, , i also faced the same issue here, i could not execute  fastboot oem unlock, when i hit reboot bootloader the system reboots with blank screen and holds on terminal without any prompt, i need to press Ctrl + c to get myself into U boot , i tried to use fastboot commands, but i get error saying 

u-boot=> fastboot oem unlock
fastboot - use USB Fastboot protocol

fastboot <USB_controller>
- run as a fastboot usb device

When i change command to fastboot sd or fastboot USB, then it removes uboot prompt and waits infinite, until i hit ctrl +c, 

Please guide me.

I am trying to explore on internet, but the solutions are not working for me.

I want boot animation to run, and for that i think placing it into /system/media shall do my work, but to do so i want write permission, i am not able to mount /system because  mount: '/system' not in /proc/mounts, to do so i think i need to boot myself into fastboot mode, i am not able to do so as fastboot is not able to execute itself ( or i am not able to get that done ). I also tried to change the setenv to androidboot.dm_verity=disable, still no luck.

On device when i hit whoami, i get root.

My i.MX8mm also has USB debugging On and also OEM setting On. 

Thanks in Advance !!!!!


Sahil Kulkarni

0 Kudos
1 Reply

NXP TechSupport
NXP TechSupport



Please note that the adb commands and the fastboot oem unlock should be run on your host pc no in the device you're trying to get access to.


Also, the threads that you mentioned are correct and just need some modifications for it to work on your i.MX 8MM and android P9.


Sometimes the host PC selects an incorrect driver model of the USB devices, leading to the PC inability to find fastboot device, please follow this steps


1.- Run "reboot bootloader" in console after boot (device side)


2.- in host side open "Computer Management->Device Manager", you'll note that the USB appears as:

Universal Serial Bus devices -> USB download gadget


3.- Right click it, and choose “Updated Driver -> browse my computer for driver software -> let me pick from a list of available drivers on my computer”, clear “Show compatible hardware” item, then choose “ADB devices”.


4.-Select yes to the pop-up window, this will select the USB as an ADB device.

Now please reboot your device and wait till it has booted, then please follow this steps to disable verity so you can remount:

> reboot bootloader (device side)

Wait until it enters U-boot


$ fastboot oem unlock (host side)

Wait until unlock is done

Reboot your device by pressing the reset button on your board

With this you should be able to run the commands on your host to update the boot animation:

$ adb start-server

$ adb root

$ adb disable-verity

$ adb reboot   (wait until the device has booted completely)

$ adb remount

$ adb push <path where your file is located>\ /system/media

Wait until it finish

$ adb reboot


This should get it done

Hope this helps,

Best regards,


- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.

0 Kudos