Disabling Debug UART on i.mx6 Sabre Board using Windows 10 IoT Core

Showing results for 
Search instead for 
Did you mean: 

Disabling Debug UART on i.mx6 Sabre Board using Windows 10 IoT Core

Contributor I

I am developing an UWP app on the i.mx6 Sabre board (MCIMX6Q - SDB)  running Windows 10 IoT Core which needs to utilize a serial port. It seems like the only port available is UART1, which is used as the kernel debug port by default and I need to disable that feature that my app can have access to that port. Is that correct?

The i.MX_Win10 user guide says 

"To enable the UART, the kernel debugger must be disabled by running the following
command on the device and rebooting. The UART exposed is the same UART that the
kernel debugger uses. bcdedit /debug off"

Can someone provide some more detailed instructions as to how to do this? During bootup, I see a message that says "Press escape for boot options" but nothing happens when I press escape.

If I type in "bcdedit /debug off" into IoTPowerShell (which is how that I use to build the image), I get a message saying "An error occurred while attempting to modify the debugger settings.
The value is protected by Secure Boot policy and cannot be modified or deleted."

Thanks in Advance.

1 Reply

NXP Employee
NXP Employee


To disable kernel debugger and enable UART for applications you have to conect to board over SSH. For guide on how to do it is you can follow this link under section "Using PuTTY".

Secure Shell (SSH) - Windows IoT | Microsoft Docs 

When connected to device over SSH type bcdedit /debug off, this will enable UART to user. After that the device needs to reboot, for that type shutdown /r 5.

After reboot UART should be available. You can check that by using Windows example BusTool MinComm with parameter -list.

Windows-iotcore-samples/BusTools/MinComm at develop · microsoft/Windows-iotcore-samples · GitHub 

Hope this helps.