Can't find PMIC:PCA9450

cancel
Showing results for 
Search instead for 
Did you mean: 

Can't find PMIC:PCA9450

113 Views
Contributor III

Hello NXP TechSupport

i.MX 8M Nano EVK

# Solved :-

1]  Issue of PMIC has solved by flashing Linux Demo image[ L5.4.3_1.0.0_MX8MN (REV LF_L5.4.3_1.0.0 ) ], having PMIC : BD71850MWV

# Error 1 :-

2]  But previously 1 month ago i had tried to flash a Linux Demo Image [ L5.4.24_2.1.0_MX8MN (REV L5.4.24_2.1.0 ) ] but it didn't work at that time, shown can't find PMIC : PCA9450.

# Error 2 :-

3] And after that I had also tried Yocto set up for BSP [ i.MX 8M Nano EVK ] from Yocto project User's Guide [ Rev. L5.4.24_2.1.0, 06/2020 ]

$  DISTRO=fsl-imx-xwayland MACHINE=imx8mnevk source imx-setup-release.sh -b build-xwayland
$  bitbake imx-image-full

After building above image i got all images and flashed on SD Card imx-image-full-imx8mnevk.wic

after successful flashing, getting same error as can't find PMIC : PCA9450.

# I'm attaching the Photos of result after flashing my own Yocto Image.

So, what i should i do for getting correct boot logs with my own Yocto Set up for Nano EVK  ??

 

Thanks

Nikhil

0 Kudos
2 Replies

101 Views
NXP TechSupport
NXP TechSupport

Hi nikhil29,

i.MX8MN has 2 versions of Evaluation Board, one is i.MX8MN + BD71837, the other is I.MX8MN + PCA9450. 2 Boards are both supported in linux bsp.

According to your log, the evk board you are using is i.MX8MN + BD71837, you should remove CONFIG_POWER_PCA9450 in u-boot/include/configs/imx8mn_evk.h, then re-compile images.

See spl.c, you will know why  :

#include <power/pmic.h>
#ifdef CONFIG_POWER_PCA9450
#include <power/pca9450.h>
#else
#include <power/bd71837.h>

.......

Have a nice day!

B.R,

Weidong

0 Kudos

89 Views
Contributor III

Thanks Weidong for your time

I have done the changes that you told me in imx8mn_evk.h, but after re-compilation of bootloader error occurs,

Error :- 

/home/nikhil/i.MX8M-Nano/imx-yocto-bsp/build-xwayland/tmp/work/imx8mnevk-poky-linux/u-boot-imx/1_2020.04-r0/git/scripts/Makefile.spl:420: recipe for target 'spl/u-boot-spl' failed
| make[2]: *** [spl/u-boot-spl] Error 1
| /home/nikhil/i.MX8M-Nano/imx-yocto-bsp/build-xwayland/tmp/work/imx8mnevk-poky-linux/u-boot-imx/1_2020.04-r0/git/Makefile:1861: recipe for target 'spl/u-boot-spl' failed
| make[1]: *** [spl/u-boot-spl] Error 2
| make[1]: Leaving directory '/home/nikhil/i.MX8M-Nano/imx-yocto-bsp/build-xwayland/tmp/work/imx8mnevk-poky-linux/u-boot-imx/1_2020.04-r0/build/imx8mn_evk_config'
| Makefile:167: recipe for target 'sub-make' failed
| make: *** [sub-make] Error 2
| make: Leaving directory '/home/nikhil/i.MX8M-Nano/imx-yocto-bsp/build-xwayland/tmp/work/imx8mnevk-poky-linux/u-boot-imx/1_2020.04-r0/git'
| WARNING: exit code 1 from a shell command.
|
ERROR: Task (/home/nikhil/i.MX8M-Nano/imx-yocto-bsp/sources/meta-imx/meta-bsp/recipes-bsp/u-boot/u-boot-imx_2020.04.bb:do_compile) failed with exit code '1'
NOTE: Tasks Summary: Attempted 408 tasks of which 407 didn't need to be rerun and 1 failed.

Summary: 1 task failed:
/home/nikhil/i.MX8M-Nano/imx-yocto-bsp/sources/meta-imx/meta-bsp/recipes-bsp/u-boot/u-boot-imx_2020.04.bb:do_compile
Summary: There was 1 WARNING message shown.
Summary: There were 2 ERROR messages shown, returning a non-zero exit code.

0 Kudos