RAppID tool issue with K line

Showing results for 
Search instead for 
Did you mean: 

RAppID tool issue with K line

Contributor III

Hello NXP team,

We are using S32K1XX controller in our project.

I have used the RappID tool for the application flashing.

I have downloaded rbf file from NXP forum and tried to flash the application using RappID Tool  through UART1 lines.

successfully flashed the application to the target board.

I have tried to flash the application through K line interface , application is not flashing.

Problem 1 :

 just want to know the reason , is it because of Transmission and reception is on the same line or TXINV bit not set in UART configuration in the rbf file(For K line , TXINV bit need to set in the UART configuration)?

if it is the TXINV bit set , then shall we get the TXINV = 1 bit configuration rbf file?

Problem 2 :

Shall we use the same rbf file for CAN and UART communication for the flashing(RAppID supports only CAN and UART interfaces)?

find the attached rbf file which we used for the application flashing.

Kindly let me know regarding this .

This is high priority for us to test or flash the application.



Tags (1)
0 Kudos
0 Replies