Use 12v supply,NXP S32K146 Red LED is blink

cancel
Showing results for 
Search instead for 
Did you mean: 

Use 12v supply,NXP S32K146 Red LED is blink

292 Views
2868108923
Contributor I

hi all

when I use 12v supply,The SDA_RST_LED is blink. if I use the usb supply the power, all thing is ok, I can use S32 Design Studio for ARM  to debug and run code.

I need to use Can , send and recieve data ,if not use 12v,It seems Can0 not function(

UJA1169TK/F need the 12v power ?)

I want to use CAN transceiver to send and recieve,but the NXP S32K146 GPIO high is 3.3v,This is not work ,I need the Gpio is 5v. I kown, we can use the j10 to control the 3.3/5v,but it seems not work.

best regarts

blink_pic.png

 

0 Kudos
9 Replies

290 Views
2868108923
Contributor I

I read NXP S32K144 EVB Reset LED continuously ON ,and use the firware,my D2 is blink.

It seems we have different things to do, I can use usb supply the power  to make the mcu work

0 Kudos

275 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

The example documentation can be found in the S32 SDK documentation at Examples and Demos section. (<SDK_PATH>/doc/Start_Here.html)
This mentioned that you need to use an external 12V power supply.

description can_pal_s32k146.png

CAN PAL.png

The image of your board shows that the setting of J10 need to change pin2-3. 

J10 23.pngJ104 12.pngJ107 12.png

Please check if the version is SCH-29844 REV B at the bottom side of S32K146EVB.

Best Regards,
Robin
-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

266 Views
2868108923
Contributor I

Hi Robin

  Thank you for your reply. after read the schematic design and documentation, I konw I should  use the external 12V power supply to use Can demo. but the thing is that when I supply the 12v power, the mcu is always  reset.  I Capture the V_TGTMCU Singal, it seems when i supply the 12v power, is generate a Pulse(like under image ). My friends help me to read the power part schematic design, but is too hard to understand.

   konw, I can S32K146 other Can(not can0,and add CAN transceiver), the problem maybe is my mcu is damage(a few days ago, i can supply the 12v power to use can demo).  I want to konw how 12v power to the mcu (read the schematic design many times,but not understand,J16 ). why the reset sigal is generate. the  documentation show " Reset signal direct to the MCU, to use when OpenSDA is not powered" ,but the thing is OpenSDA have the power,D2 is green .

best regarts

0 Kudos

255 Views
2868108923
Contributor I

 when The mcu J104 is 1-2 ,Has the same mistake.

0 Kudos

264 Views
2868108923
Contributor I

OXXEZR8X4ND_QRURLB`G&#125;[L.jpg

N[K2LOV2P1935BB2TQJOE&#125;2.png

  

`SPCP%{G6X)N{EP~EQ3ZUZO.jpg

0 Kudos

250 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

Does the D2 still blink?
In normal mode, the small green LED nearby the OpenSDA K20 device is off. And in BOOTLOADER mode the green LED blinks an error code.
The LED error codes are in section 3 of : http://www.nxp.com/files/32bit/doc/user_guide/OPENSDAUG.pdf:

opensda-led-error-codes.png
OpenSDA LED Error Codes

Please try to Enter OpenSDA Bootloader Mode and then click SDA_INFO.HTML check the Application Version.

Application Version.png
If there is something wrong with Application Version of OpenSDA, please fix it first.
Otherwise I don't think you can debug and run code by using S32DS for ARM.

 

The pulse waveform is measured at V_TGTMCU or Pin3 of J104?
V_TGTMCU is power from VDD.

V_TGTMCU from VDD.png 

The pulse at Pin3 of J104 can be caused by MCU itself.(For example there is no program in it.)

J104 12 V_TGTMCU.png

 

0 Kudos

227 Views
2868108923
Contributor I

Hi Robin

 thank you for your reply,when I only use 12v power,red d1 is blink, green d2 is off, green d3 is  on.And it look something give the reset signal to the mcu,when I change the PTA5 to GPIO output( not  RST_TGTMCU_B function ),my code can run ok(but can not to debug the code, when I debug ,change the PAT5 function?)

our Hardware Engineer is help me to analyse the problem.but we has less experience to NXP, we think the mcu  NTSX2102GU8H  is broken or other problem.we capture many part to analyse . TP547(12.5V),TP522(12.4),P5V_SBC(5V) and so on.

the truely problem may 12v power generate  the reset singal, we dont konw How is generate. our team want to change the mcu,from tricore to nxp. but now,we have less experience  to nxp

best regarts

 

0 Kudos

97 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

Please fix OpenSDA first, you can refer: https://community.nxp.com/t5/S32K/S32K148EVB-Dead-after-OpenSDA-Update-Need-help-to-recover/m-p/1204...

Fix OpenSDA don't need external 12V power, so please connect 2-3 of J107.

0 Kudos

66 Views
2868108923
Contributor I

Thank your reply,in our custom board,we find the bad power will affect the  reset signal. and our  Hardware Engineer  have to solve the problem. now, we have test the custom  board function,and will give it to our customer. The EVB problem,we will test  A few weeks later. 

0 Kudos