S32k146 Debugging Remote Failure Reply.

cancel
Showing results for 
Search instead for 
Did you mean: 

S32k146 Debugging Remote Failure Reply.

156 Views
BrandonPhelps
Contributor I

I'm currently developing on the S32K146 platform and am using freertos. 

During the debugging my application I run into a situation where debugging through the IDE becomes unusable. This occurs when I press the suspend button on the IDE. The resultant debug stack looks like

BrandonPhelps_0-1632766454163.png

 

Additionally when I'll get some additional trace information from the Debugger Console indicating that reading the registers values will fail. 

Note that this remote failure reply occurs when I run 'set debug remote 1' into the Debugger Console. Then run the 'info thread' command.

BrandonPhelps_1-1632766502010.png

It appears as if reading out the stack information for one of the task fails. 

Referring to this documentation on the packets that gdb sends https://sourceware.org/gdb/onlinedocs/gdb/Packets.html it appears an error occurs on the reading of the registers. however I'm not certain how to interpret this error. 

BrandonPhelps_2-1632771988668.png

 

I am using a PE micro Universal FX as the debugging hardware. And have updated to the newest PE micro plugin drivers, version 5.0.

I believe I'm having a similar issue to the individual in this thread. https://community.nxp.com/t5/S32K/Remote-failure-reply-when-debug-using-pemicro/td-p/1270205 As per this thread I did check some of the options such as the flash algorithm and persistence. They don't seem unusual to me, however I'm not certain what to check for explicitly. 

 

doing some additional testing I do that when I setup freertos to use dynamic memory allocation and then let , that this behaviour of the debugger becoming unstable/ unuseable goes away. 

When attempting to set this up on a basic example application, I can only reproduce these similar issues but only if I pause or step during freertos maintance handling step of uxRemoveList  on a ulNotifyTask.


Overall I'm looking for some thoughts on how to troubleshoot this.

0 Kudos
0 Replies