There is no default config and policy files for FMC in SDK 0.4

cancel
Showing results for 
Search instead for 
Did you mean: 

There is no default config and policy files for FMC in SDK 0.4

225 Views
Contributor I

Hi,

    I tried downloading both SDK 0.4 and SDK 0.5 from NXP website, SDK 0.4 does not have default config and policy files for FMC tool, whereas SDK 0.5 has config and policy files under etc/fmc/config/private/<board name >/<RCW>/config.xml and policy_ipv4.xml.

    Is this files not required in SDK 0.4 version ?

Thanks,

Manjunath

0 Kudos
2 Replies

6 Views
NXP TechSupport
NXP TechSupport

SDK 0.4 is missing a package that provides pre-built FMC  confguration files, eth-config. DPAA kernel driver starts with some workable queue configuration without FMC invocation from the userland, so basic connectivity will work under rev 0.4. If, however, you are to work with  a custom FMAN configuration under 0.4,  create both files by hand, bring them from NXP git (sdk/eth-config.git - Ethernet configuration ), or better, move to SDK 0.5.


Have a great day,
Platon

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

6 Views
Contributor I

Hi Platon,

       Thanks for suggestion, will try getting eth-config from NXP git.

   I had initially tried SDK 0.5 but faced issues, not able to ping, FMC crashes. Both issues i have posted here but no solution.

https://community.freescale.com/message/629960?et=watches.email.thread#comment-629960

FMC crashes

Thanks,

Manjunath

0 Kudos