Not able to use MDEU with talitos

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

Not able to use MDEU with talitos

ソリューションへジャンプ
664件の閲覧回数
jlsec
Contributor I

Hi,

I'm using a P1021 (SEC3.3.2) with a Linux Kernel 3.18. I have selected the Talitos option in the menuconfig and compiled the cryptodev 1.8.

During the kernel loading I can see that all algorithms are correctly registered.

To check if there is any performance improvement I use openssl compiled to use cryptodev (openssl speed -evp <algorithm>)

With aes-xxx-cbc I can see a significant improvement so I guess it's using the SEC.

The problem comes with all the hasing algorithms performed by the MDEU. With them there are no improvements and the performance is the same without cryptodev.

Is there any other way to check if talitos is working fine? Do I need to use other version of talitos?

Thanks.

タグ(2)
0 件の賞賛
1 解決策
531件の閲覧回数
bpe
NXP Employee
NXP Employee


Both OpenSSL and Cryptodev driver require multiple patches and specific build options to work correctly with SEC. Use the most recent QorIQ SDK that supports your processor (1.9) to build OpenSSL and cryptodev in a known-good
configuration. Refer to SDK 1.9 Manual, Sections 7.4.5, 9.7 for instructions on building and verification.  Visit the link below for SDK download links:

http://www.nxp.com/products/software-and-tools/run-time-software/linux-sdk/linux-sdk-for-qoriq-proce...


Have a great day,
Platon

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

元の投稿で解決策を見る

0 件の賞賛
2 返答(返信)
532件の閲覧回数
bpe
NXP Employee
NXP Employee


Both OpenSSL and Cryptodev driver require multiple patches and specific build options to work correctly with SEC. Use the most recent QorIQ SDK that supports your processor (1.9) to build OpenSSL and cryptodev in a known-good
configuration. Refer to SDK 1.9 Manual, Sections 7.4.5, 9.7 for instructions on building and verification.  Visit the link below for SDK download links:

http://www.nxp.com/products/software-and-tools/run-time-software/linux-sdk/linux-sdk-for-qoriq-proce...


Have a great day,
Platon

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 件の賞賛
531件の閲覧回数
jlsec
Contributor I

Hi Platon,

As you point the problem was with the OpenSSL. Cryptodev is working fine and using talitos (I have tested it using the hashing sha test that is provided with the source code).

The OpenSSL compiling flag -DUSE_CRYPTODEV_DIGESTS was misspelled and thats the explanation of the problem.

Best regards!

0 件の賞賛