RDVCU5775EVM SBC problems

cancel
Showing results for 
Search instead for 
Did you mean: 

RDVCU5775EVM SBC problems

Jump to solution
144 Views
Contributor I

Hi, I'm using the RDVCU5775EVM board for BMS development, the board is connect the 12V power supply on connector J8's A11 and A21, when I power up with the jumper J1(SBC debug pin) attached, the board can power-up correctly(I have download the demo BMS program inside the MCU), and the promgramming is running, because the LED GPIO1&2  blink. But, when I remove the jumper J1, and power up board again, I can see the led D54(reset) blink several times and the board power down. I guess the KL15_WAKE is using for wake up the SBC and I try to connect the KL15_wake to +12V, the board just powered like 2 seconds and shut down as well.

So, my question is:

1, My connection correct or not?

2, Does LED D54 blink during reset term is correct? 

3, How to set up the SBC during reset term?

Thanks for helping!

Best regards,

0 Kudos
1 Solution
108 Views
NXP TechSupport
NXP TechSupport

And also forwarding another his comment:

I have reproduced this problem in SDK-based projects at the O0 level of GCC optimization, but it works at the O1, O2, and O3 levels.

At the O0 level, it exceeds the maximum time 256ms of SBC first watchdog refresh, I'm working on fixing the issue.

Current workaround: Change the GCC optimization level to at least O1.

View solution in original post

0 Kudos
3 Replies
109 Views
NXP TechSupport
NXP TechSupport

And also forwarding another his comment:

I have reproduced this problem in SDK-based projects at the O0 level of GCC optimization, but it works at the O1, O2, and O3 levels.

At the O0 level, it exceeds the maximum time 256ms of SBC first watchdog refresh, I'm working on fixing the issue.

Current workaround: Change the GCC optimization level to at least O1.

View solution in original post

0 Kudos
62 Views
Contributor I

Thanks David!

0 Kudos
108 Views
NXP TechSupport
NXP TechSupport

I have forwarded these question to RDVCU5775EVM project owner and here there are the answers:

1, My connection correct or not?
Correct.

2, Does LED D54 blink during reset term is correct?
It shouldn’t blink several times. That indicates the MCU failed to refresh the SBC watchdog during the 256ms from power-up in the non-debug mode.

3, How to set up the SBC during reset term?
Make sure that MCU refreshes the SBC watchdog during the 256ms from power-up.

Now the SDK-based project we provided has an issue that can’t refresh SBC watchdog first time under the O0 optimization level for GCC, I’m working on fixing this issue, suggest the user change the GCC optimization level to at least O1, that is ok I tested.

0 Kudos