Unable to connect to MKE04Z8 with USBDM JS16-SWD

cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to connect to MKE04Z8 with USBDM JS16-SWD

367 Views
Contributor I


Hi,

 

I have spent several hours with debugging this case without any success. I would ask for your help!

 

We made a hardware with an MKE04Z8VTG4 and we have build our own JS16-SWD programmer.

Unfortunatelly is is not possible to access to the MCU via SWD. Clicking on the Detect Chip button prompts an error dialog with the message: "Failed to probe target Reason: BDM has no connection to target"

 

We have tried to Mass Erease the MCU with clicking the Mass Erase Now button, but that did not solve the problem.

We have tried to connect to our hardware via a FRDM-KL46Z board using USBDM but the result was exactly the same.

We have captured some scope shot about the communication. The obvious SWD protocol documentation was not found on the internet but it seems that the MCU does not reply to any SWD request.

 

I attached the USBDM screenshots and the scope shot.

 

We do not have any idea how to move forward.

Have you seen similar problem?

Could you give us some advice about advanced debugging?

 

Thanks.

Best Regards,

ANewsEE

Original Attachment has been moved to: scope.csv.zip

Tags (3)
0 Kudos
2 Replies

6 Views
Senior Contributor V

Hi Istvan,

These are the waveforms I obtained with a blank S9KEAZN8 which I believe is an equivalent chip.

These were done at 2MHz connection speed using "Detect Chip" operation.

Initial connection - The reset pin is initially pulsing which is usual with  a blank chip.

pastedImage_0.png

Zooming in on the first activity:

pastedImage_2.png

Even further (not the same event - reset is not oscillating)

pastedImage_1.png

This looks a bit different to your waveform but I believe it is equivalent - Possibly a different connection speed?

Only the rising edges of clock are important.

pastedImage_0.png

For reference this was the test circuit;

pastedImage_0.png

I would check the following:

  • NMI is not being held low during reset etc
  • Example reset - it is not clear what it is doing in your waveform.

bye

0 Kudos

6 Views
Contributor I

Hi pgo,

Thanks for the answer!

I have just checked the pinout to find the NMI pin and I have found the problem.

Unfortunatelly the SWDIO and SWDCLK nets were swapped in our design.

I swapeed the signals in the programming cable and now I can detect and program the MCU.

I am so angry that we did not found this problem until now.

Your suggestion was needed to check the pinouts again and find the fault.

Thanks for your help!
BR

0 Kudos