USB VCOM on PN7360 gives unstable interrupts

cancel
Showing results for 
Search instead for 
Did you mean: 

USB VCOM on PN7360 gives unstable interrupts

121 Views
ashokry
Contributor I

Hi Folks,

I have PN7460 MCU and I am using the PN7462AU_ex_phExVCom_mcux example.

I have some binary file that contains 10 bytes.

I am trying to send it via TeraTerm 5 times (so I am sending chunks of 10 bytes, with some time gap between chunks)

The strange behavior I get is that VCOM_bulk_out_hdlr is called 13 times, with pVcom->rx_count with corrupted values (1053000).

With some other trials, I get the ISR called 5 times as expected, but the the pVcom->rx_count is 11 (so total received data is 55 where I've already sent 50 only).

I've checked the USB packet size and found it to be 64 bytes, so I've tried to send files with size multiple of 64, so I've tried 256 bytes file and expecting to get 4 interrupts, but I only get 2.

Part of the stack is precompiled in a library file: usbd_arm-none-eabi

Screenshot attached for a trial with 10 bytes file sent 5 times (with some debug code seen in the screenshot)

Any support is really appreciated !

0 Kudos
1 Reply

109 Views
ashokry
Contributor I

[UPDATE]:

I've created a python script to open the 10 bytes file and send its content over UART with 3 seconds time gap between bytes.

After a while, the reception of bytes stops, the VCOM port disappears from windows (indicating that the MCU has stopped somewhere), and Xpresso IDE crashes, where I am unable to pause to see what is the MCU status (I receive error message "Interrupt failed" when trying to pause)

Any help is much appreciated !

0 Kudos